summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-05 07:14:41 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-05 07:30:03 +0200
commiteb366d25f6f9aed0906770c0c6913eaab5321b92 (patch)
treeb16cacda08f089a66a1a21662f405dbba79a49cd /dev-python/alembic
parentdev-python/jupyterlab: Keyword 4.0.4 x86, #906773 (diff)
downloadgentoo-eb366d25f6f9aed0906770c0c6913eaab5321b92.tar.gz
gentoo-eb366d25f6f9aed0906770c0c6913eaab5321b92.tar.bz2
gentoo-eb366d25f6f9aed0906770c0c6913eaab5321b92.zip
dev-python/alembic: Bump to 1.11.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.11.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index fcba7f15e7e0..14f432b04706 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.11.1.tar.gz 1176522 BLAKE2B 5a4185cb59b48301d350db3c44487408ca6c8d88b47ddd22e4c19fad57d0961cb3968652ba15986cf42adb9bb38542a79b11ddd980c9841a071844d26fed56fd SHA512 d068d581df952c2d304534218bd8f948407e288005514501816e60600b186bf03bcc60f485c4c6d5c80caf718210c2bf619f1758327bc592663f160c3bd21e65
+DIST alembic-1.11.2.tar.gz 1192900 BLAKE2B 47919a02bfabc51caf13b70d7598bd54c63e2f3deea0a6547677433cb4dfab2fea7b199ad5288109c970386a3f318bf29ac2d931d2299dfed63883c3c4dde179 SHA512 7a3c2c723134d7d3048596dc7a98993edf737e09cea0b7df5cf5a05fbc37b9c7eb7fa28e4f1ce2adbb9c4683f838227b760feae148fbc617bc9fdd8e52c667c1
diff --git a/dev-python/alembic/alembic-1.11.2.ebuild b/dev-python/alembic/alembic-1.11.2.ebuild
new file mode 100644
index 000000000000..0fb0d2348c60
--- /dev/null
+++ b/dev-python/alembic/alembic-1.11.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # setup.cfg contains -p no:warnings in addopts which triggers
+ # datetime.utcfromtimestamp() deprecation warning as an error in py3.12
+ epytest -o addopts=
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}