summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-02 07:57:05 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-02 08:04:16 +0100
commitc762f90e2c2f61d1dcfea70d5a0f606e3c648278 (patch)
tree220ad8dd6d0c704dd0b1969f8bd558e45ae2c7f9 /dev-python/alembic
parentdev-python/virtualenv: Bump to 20.25.0 (diff)
downloadgentoo-c762f90e2c2f61d1dcfea70d5a0f606e3c648278.tar.gz
gentoo-c762f90e2c2f61d1dcfea70d5a0f606e3c648278.tar.bz2
gentoo-c762f90e2c2f61d1dcfea70d5a0f606e3c648278.zip
dev-python/alembic: Bump to 1.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.13.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index a668b93572e1..c106247e9568 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.12.1.tar.gz 1200204 BLAKE2B 640435e09ee7d33c7fa375b6fa784e2ef4097b50074753341717bc21fa8bd838ca00ced6c5cc9e3d82eca494270ffe84bc4b74dc96ed01cb9aded77f21e33520 SHA512 c76bae8f22dcbb4b2d235a17059a756c33bf40d4ea62b937373a29dab7c4f6e36eef0030a721222663c191eba565530299d28726f06e0c40d74daec1d3e03b33
+DIST alembic-1.13.0.tar.gz 1208438 BLAKE2B e5e3040eecd74e6095062dac51138f91b79197af6410a451f7a7ac699f8d31d12ab4e381f8b1e9ce04fd8c897339d5074493e4ef95f294276ea5d67403504229 SHA512 c9a014fc30000a09fa69e7a56cb591000443317d0cc3576fd6bd70cab7cec29906fa48d57e40dcf12d7dd93762de0d6f395fb37c9d5c1780664555757f387262
diff --git a/dev-python/alembic/alembic-1.13.0.ebuild b/dev-python/alembic/alembic-1.13.0.ebuild
new file mode 100644
index 000000000000..5d610b87ddda
--- /dev/null
+++ b/dev-python/alembic/alembic-1.13.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # setup.cfg contains -p no:warnings in addopts which triggers
+ # datetime.utcfromtimestamp() deprecation warning as an error in py3.12
+ epytest -o addopts=
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}