summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-06 04:25:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-06 05:07:37 +0200
commit37ad614f5684f56a202e7afebdb4095c25222c16 (patch)
tree1c7791a6fe691df727542fda240cc63afa42a017 /dev-python/alembic
parentsys-apps/flatpak: add systemd flatpak-update.{service.timer} (diff)
downloadgentoo-37ad614f5684f56a202e7afebdb4095c25222c16.tar.gz
gentoo-37ad614f5684f56a202e7afebdb4095c25222c16.tar.bz2
gentoo-37ad614f5684f56a202e7afebdb4095c25222c16.zip
dev-python/alembic: Bump to 1.10.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.10.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 9d1e1e08843a..687555373680 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,2 +1,3 @@
DIST alembic-1.10.2.tar.gz 1148340 BLAKE2B e6882982d0c7f10aadce3118e0d7ec84de9ecd123b55351922876fedcd5e1debe8aacac57a4db25a0296c585569d6118b95aa5dc601841f5c4247f21fcfd917f SHA512 a0ebff90521a4358257892b840d3e623d35bc2c32408759b7d5ae25839a5314e58ea40457f79e766d1cfad467ebe8b663e073aebd89141e11aee1992b40ee1e9
+DIST alembic-1.10.3.tar.gz 1151146 BLAKE2B 3b84ca71431b0a55c91413f4586f85e5e7c8f8d107755fca7694dca431b96c6e6a9abc9b67a8d86c348cb194e18553761bb8d4a3957a6479cfc57cb92de8b490 SHA512 5665ae9429a6b828b6357bde170e011ef5a18cb5642c5b5ade123046dfbad307c238c0188b4c35db59217c7921f43b2b92192b84b51ee269a39766957ca0be7f
DIST alembic-1.9.4.tar.gz 1139210 BLAKE2B 5b740803b6bf5b715e9572a91d87d5403d64e665647776d28511704fa17ed81825fe6f5cdab2cec77a0806abb02ef2a7acf5f9702ff87639b90e74d9e22a4b1a SHA512 76e6f86e789cecff78f8e86c34d22a70615158833bc24a26f38fe2d0d5ccd098920e0fe4cbebaadd2c9a4a2e63152720945645000d46a2b6b8b6696ce873f899
diff --git a/dev-python/alembic/alembic-1.10.3.ebuild b/dev-python/alembic/alembic-1.10.3.ebuild
new file mode 100644
index 000000000000..65822a6ad910
--- /dev/null
+++ b/dev-python/alembic/alembic-1.10.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}