summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2017-05-23 08:13:21 +0200
committerSlawomir Lis <slis@gentoo.org>2017-05-23 12:37:15 +0200
commit40b32e76871775517a83ac85c84cec48afe721f1 (patch)
treee4d0cdd6a336aa803f7775e72138a3b233cdd980 /dev-python/aldryn-search/aldryn-search-0.3.0.ebuild
parentdev-python/aldryn-common: updated to use PYTHON_USEDEP (diff)
downloadgentoo-40b32e76871775517a83ac85c84cec48afe721f1.tar.gz
gentoo-40b32e76871775517a83ac85c84cec48afe721f1.tar.bz2
gentoo-40b32e76871775517a83ac85c84cec48afe721f1.zip
dev-python/aldryn-search: Updated to use PYTHON_USEDEP
Also dropped some PYTHON_COMPAT. Reported in bug 618924 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/aldryn-search/aldryn-search-0.3.0.ebuild')
-rw-r--r--dev-python/aldryn-search/aldryn-search-0.3.0.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/dev-python/aldryn-search/aldryn-search-0.3.0.ebuild b/dev-python/aldryn-search/aldryn-search-0.3.0.ebuild
index cea9921406e1..f799ed83fa63 100644
--- a/dev-python/aldryn-search/aldryn-search-0.3.0.ebuild
+++ b/dev-python/aldryn-search/aldryn-search-0.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
@@ -17,16 +17,16 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/lxml
- >=dev-python/django-1.4
- dev-python/django-appconf
- >=dev-python/django-cms-3.0
- >=dev-python/django-haystack-2.0.0
- dev-python/django-spurl
- dev-python/django-standard-form
- >=dev-python/aldryn-common-1.0.2
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/django-1.4[${PYTHON_USEDEP}]
+ dev-python/django-appconf[${PYTHON_USEDEP}]
+ >=dev-python/django-cms-3.0[${PYTHON_USEDEP}]
+ >=dev-python/django-haystack-2.0.0[${PYTHON_USEDEP}]
+ dev-python/django-spurl[${PYTHON_USEDEP}]
+ dev-python/django-standard-form[${PYTHON_USEDEP}]
+ >=dev-python/aldryn-common-1.0.2[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
- dev-python/setuptools
+ dev-python/setuptools[${PYTHON_USEDEP}]
"