summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-26 15:03:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-26 17:09:26 +0200
commitecdcf789a6067ea9432538b7cf2744d3496a3edf (patch)
tree8f06a5e9c612c9f8c8655925250c32db795b7a9b /dev-php
parentdev-php/sebastian-code-unit-reverse-lookup: drop 1.0.1, 1.0.2 (diff)
downloadgentoo-ecdcf789a6067ea9432538b7cf2744d3496a3edf.tar.gz
gentoo-ecdcf789a6067ea9432538b7cf2744d3496a3edf.tar.bz2
gentoo-ecdcf789a6067ea9432538b7cf2744d3496a3edf.zip
dev-php/PEAR-XML_RSS: drop 1.1.0_alpha1, 1.1.0, 1.1.0-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-XML_RSS/Manifest1
-rw-r--r--dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r1.ebuild29
-rw-r--r--dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0.ebuild17
-rw-r--r--dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild30
4 files changed, 0 insertions, 77 deletions
diff --git a/dev-php/PEAR-XML_RSS/Manifest b/dev-php/PEAR-XML_RSS/Manifest
index cb7ff93ab91a..b7255163d08b 100644
--- a/dev-php/PEAR-XML_RSS/Manifest
+++ b/dev-php/PEAR-XML_RSS/Manifest
@@ -1,2 +1 @@
DIST XML_RSS-1.1.0.tgz 8178 BLAKE2B da290ea2e656372478435451b5043f3254e1a06423495c62c753b636208ece31e5b9aebe59a9b84254aac70d2088b4c35f78b763b6045d29c467ff0989bbc6fa SHA512 947b040ec71728328bad0130da874132c12e8c14a37f57b0ebc4e9db26aed49d0f9702e20ae401bd92782e1895de71dbd5daf09adebec0eaf268c77dfe183c24
-DIST XML_RSS-1.1.0a1.tgz 6717 BLAKE2B f38aaa6981d94668031272cd48f5648ce9fec499fde4627b6291d1a9c0dea4db72779e3ce7a089be9ee5d23ad56d05c6bd3ffce031b9ef3f4fac5360c3da4420 SHA512 e88c7618cad60a775c07ac26aedf05b7ce7ab3c9f012f3e638031b3567227db237ee2e1238fa051f9f415388a5d7c131af02b8200e08c01a9078654ea5877ce8
diff --git a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r1.ebuild b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r1.ebuild
deleted file mode 100644
index 0946a4139818..000000000000
--- a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit php-pear-r2
-
-DESCRIPTION="PHP parser for RDF and RSS documents"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-php/PEAR-XML_Parser"
-BDEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
-
-src_prepare() {
- default
- sed -i \
- -e 's/_Framework_/\\Framework\\/' \
- -e 's/_TextUI_/\\TextUI\\/' \
- tests/*.php
-}
-
-src_test() {
- phpunit --bootstrap "${S}/XML/RSS.php" \
- --cache-result-file="${T}/test-results.cache" tests || die
-}
diff --git a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0.ebuild b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0.ebuild
deleted file mode 100644
index f564a5c6a962..000000000000
--- a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit php-pear-r2
-
-DESCRIPTION="PHP parser for RDF and RSS documents"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE=""
-
-# Only needs PEAR_Exception (not in the tree), not all of PEAR.
-# This can be made into an || dependency if we add PEAR_Exception.
-RDEPEND=">=dev-php/PEAR-PEAR-1.10.1
- dev-php/PEAR-XML_Parser"
diff --git a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild b/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild
deleted file mode 100644
index 482610a92823..000000000000
--- a/dev-php/PEAR-XML_RSS/PEAR-XML_RSS-1.1.0_alpha1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_PV="${PV/_/}"
-MY_PV="${MY_PV/alpha/a}"
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="PHP parser for RDF and RSS documents"
-HOMEPAGE="https://pear.php.net/package/XML_RSS"
-SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-IUSE=""
-
-# Only needs PEAR_Exception (not in the tree), not all of PEAR.
-# This can be made into an || dependency if we add PEAR_Exception.
-RDEPEND="dev-lang/php:*
- dev-php/PEAR-PEAR
- dev-php/PEAR-XML_Parser"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- insinto /usr/share/php
- doins -r XML
-}