summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-07-11 20:38:34 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-07-11 21:43:40 +0300
commit25d1baa1aec4da21e072747d3fda0aca70183167 (patch)
treeaa4421359ec7181185aa5d4bea1cfd01f8f141c3 /dev-php
parentdev-php/PEAR-Var_Dump: treeclean (diff)
downloadgentoo-25d1baa1aec4da21e072747d3fda0aca70183167.tar.gz
gentoo-25d1baa1aec4da21e072747d3fda0aca70183167.tar.bz2
gentoo-25d1baa1aec4da21e072747d3fda0aca70183167.zip
dev-php/PEAR-XML_Parser: treeclean
Bug: https://bugs.gentoo.org/933998 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-XML_Parser/Manifest1
-rw-r--r--dev-php/PEAR-XML_Parser/PEAR-XML_Parser-1.3.8-r1.ebuild29
-rw-r--r--dev-php/PEAR-XML_Parser/files/XML_Parser-1.3.8-php8.patch66
-rw-r--r--dev-php/PEAR-XML_Parser/metadata.xml9
4 files changed, 0 insertions, 105 deletions
diff --git a/dev-php/PEAR-XML_Parser/Manifest b/dev-php/PEAR-XML_Parser/Manifest
deleted file mode 100644
index 2c469207592e..000000000000
--- a/dev-php/PEAR-XML_Parser/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST XML_Parser-1.3.8.tgz 13534 BLAKE2B c0227d48b43b9b0fec3251c81e56017344101b4a2dc9a5eb85310d1130148a1d7e365b3b6e3f4fcab03aeac1f702f81f22d45c4db67ff515836ef8a173cd7d4c SHA512 f840acf2e068d642177d37958487021b5bf57cd33048738f2f18fa35d83dfe428ce327900a9a141c2a184e4dbdddc9e8eefaf87604131f516f016aee30aad603
diff --git a/dev-php/PEAR-XML_Parser/PEAR-XML_Parser-1.3.8-r1.ebuild b/dev-php/PEAR-XML_Parser/PEAR-XML_Parser-1.3.8-r1.ebuild
deleted file mode 100644
index 7987d5c009aa..000000000000
--- a/dev-php/PEAR-XML_Parser/PEAR-XML_Parser-1.3.8-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit php-pear-r2
-
-DESCRIPTION="XML parsing class based on PHP's SAX parser"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ~hppa ppc64 ~s390 sparc x86"
-IUSE=""
-# This is to match patch compatibility
-RDEPEND="!<dev-php/PEAR-XML_RSS-1.1.0-r2"
-
-PATCHES=( "${FILESDIR}/XML_Parser-1.3.8-php8.patch" )
-
-src_test() {
- peardev run-tests -r || die
-}
-
-pkg_postinst() {
- php-pear-r2_pkg_postinst
- elog 'This version includes a PHP 8 compatibilty patch for startHandler'
- elog 'which removes the pass-by-reference off of $attribs (third parameter).'
- elog 'This could break old scripts with recent versions until that override also'
- elog 'removes the pass-by-reference.'
-}
diff --git a/dev-php/PEAR-XML_Parser/files/XML_Parser-1.3.8-php8.patch b/dev-php/PEAR-XML_Parser/files/XML_Parser-1.3.8-php8.patch
deleted file mode 100644
index 8115fd8d7297..000000000000
--- a/dev-php/PEAR-XML_Parser/files/XML_Parser-1.3.8-php8.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff -aruN a/XML/Parser.php b/XML/Parser.php
---- a/XML/Parser.php 2022-01-10 11:32:08.624378884 -0500
-+++ b/XML/Parser.php 2022-01-10 11:47:09.581396869 -0500
-@@ -651,12 +651,12 @@
- *
- * @param mixed $xp ??
- * @param mixed $elem ??
-- * @param mixed &$attribs ??
-+ * @param mixed $attribs ??
- *
- * @return null
- * @abstract
- */
-- function startHandler($xp, $elem, &$attribs)
-+ function startHandler($xp, $elem, $attribs)
- {
- return null;
- }
-diff -aruN a/tests/001.phpt b/tests/001.phpt
---- a/tests/001.phpt 2019-04-10 14:18:52.000000000 -0400
-+++ b/tests/001.phpt 2022-01-10 11:46:50.341458673 -0500
-@@ -13,10 +13,10 @@
- require_once "XML/Parser.php";
-
- class __TestParser1 extends XML_Parser {
-- function startHandler($xp, $element, &$attribs) {
-+ function startHandler($xp, $element, $attribs) {
- print "<$element";
- reset($attribs);
-- while (list($key, $val) = each($attribs)) {
-+ foreach ($attribs as $key => $val) {
- $enc = htmlentities($val);
- print " $key=\"$enc\"";
- }
-diff -aruN /tests/002.phpt /tests/002.phpt
---- a/tests/002.phpt 2019-04-10 14:18:52.000000000 -0400
-+++ b/tests/002.phpt 2022-01-10 11:46:58.281433169 -0500
-@@ -13,10 +13,10 @@
- require_once "XML/Parser.php";
-
- class __TestParser2 extends XML_Parser {
-- function startHandler($xp, $element, &$attribs) {
-+ function startHandler($xp, $element, $attribs) {
- print "<$element";
- reset($attribs);
-- while (list($key, $val) = each($attribs)) {
-+ foreach ($attribs as $key => $val) {
- $enc = htmlentities($val);
- print " $key=\"$enc\"";
- }
-diff -aruN /tests/003.phpt /tests/003.phpt
---- a/tests/003.phpt 2019-04-10 14:18:52.000000000 -0400
-+++ b/tests/003.phpt 2022-01-10 11:41:03.402573127 -0500
-@@ -13,10 +13,10 @@
- require_once "XML/Parser.php";
-
- class __TestParser3 extends XML_Parser {
-- function startHandler($xp, $element, &$attribs) {
-+ function startHandler($xp, $element, $attribs) {
- print "<$element";
- reset($attribs);
-- while (list($key, $val) = each($attribs)) {
-+ foreach ($attribs as $key => $val) {
- $enc = htmlentities($val);
- print " $key=\"$enc\"";
- }
diff --git a/dev-php/PEAR-XML_Parser/metadata.xml b/dev-php/PEAR-XML_Parser/metadata.xml
deleted file mode 100644
index 6841fa89bee8..000000000000
--- a/dev-php/PEAR-XML_Parser/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
-</maintainer>
-<stabilize-allarches/>
-</pkgmetadata>