summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-yaz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-yaz')
-rw-r--r--dev-php/pecl-yaz/Manifest2
-rw-r--r--dev-php/pecl-yaz/metadata.xml5
-rw-r--r--dev-php/pecl-yaz/pecl-yaz-1.1.6.ebuild26
-rw-r--r--dev-php/pecl-yaz/pecl-yaz-1.1.9.ebuild26
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-php/pecl-yaz/Manifest b/dev-php/pecl-yaz/Manifest
new file mode 100644
index 000000000000..afd642043233
--- /dev/null
+++ b/dev-php/pecl-yaz/Manifest
@@ -0,0 +1,2 @@
+DIST yaz-1.1.6.tgz 16464 SHA256 dd9b919ba3b2a09a9c77c847407f106512fe75979cc0689ebccef08c80719eee SHA512 5bef11616ff6fc44e75b5f6ace1b6b9c104e7a1c588e21d04c9da98262021029f3f8dca9ae53bbf7461f8cd3c2f57bac841dfd777931774f150809b5d60addc1 WHIRLPOOL bfdeb26fa749bd12172e33028b210e3c28259c8a15e31a543835ca4bd68af697379ba9a0befe3a1e69614769c8604a3683ba51b11bbf1644a9bed3edfd708032
+DIST yaz-1.1.9.tgz 18590 SHA256 9dd4da2fd6042b37a1811972134f852c94a6f6b85ca4ec5ed5d766eb27a6c401 SHA512 4d588afe60b3b219e0476fabc93a761210e8f625be167e7c2910a33ff9c1daec089d918a02b002d0c27bb7d8fbae03b8cab551d5d33f5ea971aadbaba2383739 WHIRLPOOL a9958d8db5a0934e727dec0b71283ff3d20d9a5b1e228c69f7f53a76b1638db28527adcd2381ce5a4e76d101702756508f6a135c69c02655e83bf2c63ade51ff
diff --git a/dev-php/pecl-yaz/metadata.xml b/dev-php/pecl-yaz/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/pecl-yaz/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-yaz/pecl-yaz-1.1.6.ebuild b/dev-php/pecl-yaz/pecl-yaz-1.1.6.ebuild
new file mode 100644
index 000000000000..7416b25d6d4f
--- /dev/null
+++ b/dev-php/pecl-yaz/pecl-yaz-1.1.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="yaz"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~ppc ~ppc64 ~s390 ~sh sparc x86"
+
+DESCRIPTION="This extension implements a Z39.50 client for PHP using the YAZ toolkit"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/yaz-3.0.2:0="
+RDEPEND="${DEPEND}"
+
+my_conf="--with-yaz=/usr"
diff --git a/dev-php/pecl-yaz/pecl-yaz-1.1.9.ebuild b/dev-php/pecl-yaz/pecl-yaz-1.1.9.ebuild
new file mode 100644
index 000000000000..1f4e0337f308
--- /dev/null
+++ b/dev-php/pecl-yaz/pecl-yaz-1.1.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="yaz"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="This extension implements a Z39.50 client for PHP using the YAZ toolkit"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/yaz-3.0.2:0="
+RDEPEND="${DEPEND}"
+
+my_conf="--with-yaz=/usr"