summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-18 21:00:12 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-18 21:01:16 +1300
commit81e4aceb9f9caa0fe4b68bbc67fce8ae73b364ea (patch)
tree730d1f039e076477dae8f2cf4746bffe073f6418 /dev-perl/tkispell
parentdev-perl/Types-Serialiser: EAPI6 + tests (diff)
downloadgentoo-81e4aceb9f9caa0fe4b68bbc67fce8ae73b364ea.tar.gz
gentoo-81e4aceb9f9caa0fe4b68bbc67fce8ae73b364ea.tar.bz2
gentoo-81e4aceb9f9caa0fe4b68bbc67fce8ae73b364ea.zip
dev-perl/tkispell: EAPI6 + tests
- EAPI6ify - Add basic compile tests - Make patch -p1/git am compatible - Remove extra whitespace from patch - Add missing CPAN remote-id's Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/tkispell')
-rw-r--r--dev-perl/tkispell/files/tkispell-0.18-aspell.patch46
-rw-r--r--dev-perl/tkispell/metadata.xml4
-rw-r--r--dev-perl/tkispell/tkispell-0.180.0-r1.ebuild35
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-perl/tkispell/files/tkispell-0.18-aspell.patch b/dev-perl/tkispell/files/tkispell-0.18-aspell.patch
new file mode 100644
index 000000000000..14c080db3cf3
--- /dev/null
+++ b/dev-perl/tkispell/files/tkispell-0.18-aspell.patch
@@ -0,0 +1,46 @@
+From ed7ede66c01fbae6c5de0e6dc28d991a1f27016c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
+Date: Sat, 11 Oct 2014 21:48:27 +1300
+Subject: Patch to use aspell instead of ispell
+
+---
+ Makefile.PL | 8 ++++----
+ tkispell | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 4cebdea..8a49493 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,11 +1,11 @@
+ use ExtUtils::MakeMaker;
+
+-my $ispell_bin = `which ispell`;
++my $ispell_bin = `which ispell-aspell`;
+ # The first match is for Solaris which. The second is for
+ # Linux which.
+-if (($ispell_bin =~ /no ispell/) || (length($ispell_bin) == 0)) {
+- print "Could not find locate ispell. Make sure that\n";
+- print "the ispell program is installed in a directory\n";
++if (($ispell_bin =~ /no ispell-aspell/) || (length($ispell_bin) == 0)) {
++ print "Could not find locate ispell-aspell. Make sure that\n";
++ print "the ispell-aspell program is installed in a directory\n";
+ print "named in the PATH environment variable.\n";
+ exit 1;
+ }
+diff --git a/tkispell b/tkispell
+index fbc6cc7..6bde051 100644
+--- a/tkispell
++++ b/tkispell
+@@ -14,7 +14,7 @@ my $lang = $ENV{LANG};
+ if ($lang =~ /^C$/ || ! defined ($lang)) {$lang = 'default'; }
+ my $hdict = $ENV{HOME}."/.ispell_$lang"; # Personal dictionary.
+
+-my $ispell_prog = `which ispell`;
++my $ispell_prog = `which ispell-aspell`;
+ chomp $ispell_prog;
+ my ($cw, $b1, @misspelledlist, @replacementlist, @addlist, $midx);
+ my $ifname = '';
+--
+2.16.2
+
diff --git a/dev-perl/tkispell/metadata.xml b/dev-perl/tkispell/metadata.xml
index 2b9a936fc0a1..6443d758ddad 100644
--- a/dev-perl/tkispell/metadata.xml
+++ b/dev-perl/tkispell/metadata.xml
@@ -5,4 +5,8 @@
<email>perl@gentoo.org</email>
<name>Gentoo Perl Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="cpan">tkispell</remote-id>
+ <remote-id type="cpan-module">Tk::SimpleFileSelect</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-perl/tkispell/tkispell-0.180.0-r1.ebuild b/dev-perl/tkispell/tkispell-0.180.0-r1.ebuild
new file mode 100644
index 000000000000..0522d6010a95
--- /dev/null
+++ b/dev-perl/tkispell/tkispell-0.180.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RKIES
+DIST_VERSION=0.18
+inherit perl-module
+
+DESCRIPTION="Perl/Tk user interface for ispell"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/aspell
+ dev-perl/Tk
+ virtual/perl-Carp
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.18-aspell.patch" )
+
+src_test() {
+ ebegin "Compile testing Tk::SimpleFileSelect 0.68"
+ perl -Mblib="${S}" -M"Tk::SimpleFileSelect 0.68 ()" -e1
+ if ! eend $?; then
+ echo
+ eerror "One or more modules failed compile:";
+ eerror " Tk::SimpleFileSelect 0.68"
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}