summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Test-SharedFork
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Test-SharedFork')
-rw-r--r--dev-perl/Test-SharedFork/Manifest2
-rw-r--r--dev-perl/Test-SharedFork/Test-SharedFork-0.210.0-r1.ebuild26
-rw-r--r--dev-perl/Test-SharedFork/Test-SharedFork-0.290.0.ebuild31
-rw-r--r--dev-perl/Test-SharedFork/metadata.xml12
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-perl/Test-SharedFork/Manifest b/dev-perl/Test-SharedFork/Manifest
new file mode 100644
index 000000000000..6bcda2f8f2fe
--- /dev/null
+++ b/dev-perl/Test-SharedFork/Manifest
@@ -0,0 +1,2 @@
+DIST Test-SharedFork-0.21.tar.gz 28865 SHA256 c118ca297cf9c877c625f12d2a2f916f6f425c203755f59712d63213e7811b21 SHA512 8259c0b99e90bf7b68c1c4cc32a491540b7a6b7a27f91defa2ab11c1263edf6e9f354d5adc4abf435246f15e1b03dab4d97a01a919dfd8db564c9baf19e3017e WHIRLPOOL 36d39809d3d4c88c341bc19386e3e6c900dc68afbace0c6fcbf4ecf1555bcb8620adc8a504e29eaf480def477c0ca80f60adddbe484166021f6f26511ef3c859
+DIST Test-SharedFork-0.29.tar.gz 15449 SHA256 63af7788cc35b9b7e6fa37c61220ca66abd6364d8bb90c20038e3d8241988a6e SHA512 ef392d615bc0be2fb04f27f0f1dcbaf8041a52242131c62d00357228b532087a50beae44bdb3d94f883a009741847641fed87665198b624139c762dcba5488ec WHIRLPOOL 9ebc04cde5459d973199c3511025135b398a0f19bd61d6f97cc575eac51ead451b1135de3233ed51c00eb820ad5df02a5296415f4e6e3b82402e8c84fecd2473
diff --git a/dev-perl/Test-SharedFork/Test-SharedFork-0.210.0-r1.ebuild b/dev-perl/Test-SharedFork/Test-SharedFork-0.210.0-r1.ebuild
new file mode 100644
index 000000000000..afe6af439b29
--- /dev/null
+++ b/dev-perl/Test-SharedFork/Test-SharedFork-0.210.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=TOKUHIROM
+MODULE_VERSION=0.21
+inherit perl-module
+
+DESCRIPTION="fork test"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 ~sparc x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.880.0
+ virtual/perl-Test-Harness
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Test-SharedFork/Test-SharedFork-0.290.0.ebuild b/dev-perl/Test-SharedFork/Test-SharedFork-0.290.0.ebuild
new file mode 100644
index 000000000000..7fad6c7f6295
--- /dev/null
+++ b/dev-perl/Test-SharedFork/Test-SharedFork-0.290.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=EXODIST
+MODULE_VERSION=0.29
+inherit perl-module
+
+DESCRIPTION="fork test"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-File-Temp
+ >=virtual/perl-Test-Simple-0.880.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ virtual/perl-Test-Harness
+ virtual/perl-Test-Simple
+ dev-perl/Test-Requires
+ virtual/perl-Time-HiRes
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Test-SharedFork/metadata.xml b/dev-perl/Test-SharedFork/metadata.xml
new file mode 100644
index 000000000000..a98b3722d639
--- /dev/null
+++ b/dev-perl/Test-SharedFork/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Test-SharedFork</remote-id>
+ <remote-id type="cpan-module">Test::SharedFork</remote-id>
+ <remote-id type="cpan-module">Test::SharedFork::Array</remote-id>
+ <remote-id type="cpan-module">Test::SharedFork::Scalar</remote-id>
+ <remote-id type="cpan-module">Test::SharedFork::Store</remote-id>
+ </upstream>
+</pkgmetadata>