summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-06 04:03:11 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-06 04:04:34 +1300
commit0ae4edb1f51585b30d13f1f61243b98e83b9aa95 (patch)
tree89ed5218e9db4e4537b62344b2b1ff0830bd8ba1 /dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.5.ebuild
parentdev-perl/Net-HTTP: Bump to version 6.170.0 (diff)
downloadgentoo-0ae4edb1f51585b30d13f1f61243b98e83b9aa95.tar.gz
gentoo-0ae4edb1f51585b30d13f1f61243b98e83b9aa95.tar.bz2
gentoo-0ae4edb1f51585b30d13f1f61243b98e83b9aa95.zip
dev-perl/Net-LDAPapi: Bump to version 3.0.5
- Reinstate tests, adding basic compilation tests, and making it more viable for consumers/testers to attempt test execution without needing to patch ebuilds. - Rework patches to be git-am-able. - Use DIST_EXAMPLES feature Upstream: - Fix cookie handling with MMR configuration - Fix ASN1 encoding of sync cookie Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.5.ebuild')
-rw-r--r--dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.5.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.5.ebuild b/dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.5.ebuild
new file mode 100644
index 000000000000..aa72e67283f7
--- /dev/null
+++ b/dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MISHIKAL
+DIST_EXAMPLES=( "examples/*" )
+inherit multilib perl-module
+
+DESCRIPTION="Perl5 Module Supporting LDAP API"
+HOMEPAGE="https://sourceforge.net/projects/net-ldapapi/
+ http://search.cpan.org/~mishikal/Net-LDAPapi/"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# LICENSE is given on the corresponding sourceforge project and matches the
+# default cpan/perl license
+
+RDEPEND="net-nds/openldap[sasl]
+ dev-libs/cyrus-sasl
+ >=dev-perl/Convert-ASN1-0.190.0"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker"
+
+PATCHES=(
+ "${FILESDIR}/${P}-ldap_result-no_error.patch"
+ "${FILESDIR}/${P}-test-env.patch"
+)
+
+src_configure() {
+ myconf="-sdk OpenLDAP -lib_path /usr/$(get_libdir) -include_path /usr/include"
+ perl-module_src_configure
+}
+
+src_install() {
+ mydoc="Credits Todo"
+ perl-module_src_install
+}
+
+src_test() {
+ local MODULES=(
+ "Net::LDAPapi ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ if [[ -n "${LDAP_TEST_HOST}" ]]; then
+ perl-module_src_test
+ else
+ elog "Comprehensive testing disabled without LDAP_TEST_HOST set. For details, see:"
+ elog "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+ fi
+}