summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-09-05 17:53:21 -0400
committerSam James <sam@gentoo.org>2023-09-06 13:32:05 +0100
commit9ae54b68b16fc6c87f486ba348de0a6a1e0f5f9e (patch)
tree7d7432f8f30b1c152ec6098ff9b7420e2be085b5 /dev-perl/Net-IDN-Encode
parentx11-themes/elementary-xfce-icon-theme: Bump to 0.18 (diff)
downloadgentoo-9ae54b68b16fc6c87f486ba348de0a6a1e0f5f9e.tar.gz
gentoo-9ae54b68b16fc6c87f486ba348de0a6a1e0f5f9e.tar.bz2
gentoo-9ae54b68b16fc6c87f486ba348de0a6a1e0f5f9e.zip
dev-perl/Net-IDN-Encode: Add patch for Perl 5.38
Closes: https://bugs.gentoo.org/912440 Signed-off-by: Matt Turner <mattst88@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/32639 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Net-IDN-Encode')
-rw-r--r--dev-perl/Net-IDN-Encode/Net-IDN-Encode-2.500.0-r2.ebuild30
-rw-r--r--dev-perl/Net-IDN-Encode/files/2.500.0-use-uvchr_to_utf8_flags-instead-of-uvuni_to_utf8_fla.patch41
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-perl/Net-IDN-Encode/Net-IDN-Encode-2.500.0-r2.ebuild b/dev-perl/Net-IDN-Encode/Net-IDN-Encode-2.500.0-r2.ebuild
new file mode 100644
index 000000000000..e05859eb73eb
--- /dev/null
+++ b/dev-perl/Net-IDN-Encode/Net-IDN-Encode-2.500.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=CFAERBER
+DIST_VERSION=2.500
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Internationalizing Domain Names in Applications (IDNA)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ virtual/perl-Unicode-Normalize
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/Module-Build-0.420.0
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-NoWarnings
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-use-uvchr_to_utf8_flags-instead-of-uvuni_to_utf8_fla.patch
+)
diff --git a/dev-perl/Net-IDN-Encode/files/2.500.0-use-uvchr_to_utf8_flags-instead-of-uvuni_to_utf8_fla.patch b/dev-perl/Net-IDN-Encode/files/2.500.0-use-uvchr_to_utf8_flags-instead-of-uvuni_to_utf8_fla.patch
new file mode 100644
index 000000000000..a8eff51ffd03
--- /dev/null
+++ b/dev-perl/Net-IDN-Encode/files/2.500.0-use-uvchr_to_utf8_flags-instead-of-uvuni_to_utf8_fla.patch
@@ -0,0 +1,41 @@
+https://bugs.gentoo.org/912440
+https://github.com/cfaerber/Net-IDN-Encode/pull/11
+
+From: Shin Kojima <shin@kojima.org>
+Date: Sun, 23 Jul 2023 13:15:59 +0900
+Subject: [PATCH] use uvchr_to_utf8_flags instead of uvuni_to_utf8_flags (which
+ is removed in perl 5.38.0)
+
+https://perldoc.perl.org/5.36.0/perlintern#uvuni_to_utf8_flags
+Signed-off-by: Shin Kojima <shin@kojima.org>
+---
+ lib/Net/IDN/Punycode.xs | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/lib/Net/IDN/Punycode.xs b/lib/Net/IDN/Punycode.xs
+index 211ef9c..36530dd 100644
+--- a/lib/Net/IDN/Punycode.xs
++++ b/lib/Net/IDN/Punycode.xs
+@@ -24,6 +24,10 @@
+ #define utf8_to_uvchr_buf(in_p,in_e,u8) utf8_to_uvchr(in_p,u8);
+ #endif
+
++#ifndef uvchr_to_utf8_flags
++#define uvchr_to_utf8_flags(d, uv, flags) uvuni_to_utf8_flags(d, uv, flags);
++#endif
++
+ static char enc_digit[BASE] = {
+ 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm',
+ 'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z',
+@@ -253,7 +257,7 @@ decode_punycode(input)
+ if(skip_p < re_p) /* move succeeding chars */
+ Move(skip_p, skip_p + u8, re_p - skip_p, char);
+ re_p += u8;
+- uvuni_to_utf8_flags((U8*)skip_p, n, UNICODE_ALLOW_ANY);
++ uvchr_to_utf8_flags((U8*)skip_p, n, UNICODE_ALLOW_ANY);
+ }
+
+ if(!first) SvUTF8_on(RETVAL); /* UTF-8 chars have been inserted */
+--
+2.41.0
+