summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-22 05:13:07 +0000
committerSam James <sam@gentoo.org>2023-03-22 05:13:07 +0000
commit6a36030b0057a0a62bc90aa86c340146ef4b5565 (patch)
treea4c6ebd29ad8158ef3e042e5c84eab5553865c3a /dev-perl/Moo
parentdev-perl/Modern-Perl: add github upstream metadata (diff)
downloadgentoo-6a36030b0057a0a62bc90aa86c340146ef4b5565.tar.gz
gentoo-6a36030b0057a0a62bc90aa86c340146ef4b5565.tar.bz2
gentoo-6a36030b0057a0a62bc90aa86c340146ef4b5565.zip
dev-perl/Moo: add 2.5.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Moo')
-rw-r--r--dev-perl/Moo/Manifest1
-rw-r--r--dev-perl/Moo/Moo-2.5.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Moo/Manifest b/dev-perl/Moo/Manifest
index d665516acd6d..088174db4718 100644
--- a/dev-perl/Moo/Manifest
+++ b/dev-perl/Moo/Manifest
@@ -1 +1,2 @@
DIST Moo-2.005004.tar.gz 108339 BLAKE2B 9b61a0a4867e72e277b56f684ec4b723c264cd5b87e7f38018788871870d36fc37b11e112138a762823c6aba68fc2c96d6fd6ead26c8a8f22ac432a06e8e58c4 SHA512 a1335d180cd19dc7189bc1663efd5a05650d579c5e5d049fc4059a382d1eeb882fdd9cd2b107fdd40499e22a5c6196fc47c1334145101def531e5f5fd3cd0edf
+DIST Moo-2.005005.tar.gz 108583 BLAKE2B 6b8bc157874a4d2a24dc9bd0b79b8684ecc96a3f377991997ff95a02df6d4d53bf0200665dd5a622d8ebff624a1b5793478f66acb636ab20d36b59a936eac239 SHA512 e6b6cc491bb55ab0a7a57418d210da52990e8aa559fcf83c25838624caa0de1c919a229bab2b9c7e7c99cc9904706b64db169860d2c404449731e400ea1c5f79
diff --git a/dev-perl/Moo/Moo-2.5.5.ebuild b/dev-perl/Moo/Moo-2.5.5.ebuild
new file mode 100644
index 000000000000..f7515d0c3db0
--- /dev/null
+++ b/dev-perl/Moo/Moo-2.5.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=2.005005
+inherit perl-module
+
+DESCRIPTION="Minimalist Object Orientation (with Moose compatiblity)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Class-Method-Modifiers-1.100.0
+ >=virtual/perl-Exporter-5.570.0
+ >=dev-perl/Role-Tiny-2.2.3
+ >=virtual/perl-Scalar-List-Utils-1.0.0
+ >=dev-perl/Sub-Quote-2.6.6
+ >=dev-perl/Class-XSAccessor-1.190.0-r2
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"