summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-13 04:51:54 +0000
committerSam James <sam@gentoo.org>2023-11-13 04:51:54 +0000
commit3fc84e7cb8eb0f4d7f22127b96f38241893a2c2e (patch)
tree41fa3a56e7f6fb6b800ea2ff76709a08c875e6df /dev-perl/IO-Compress-Brotli
parentmedia-video/vlc: add 3.0.20 (diff)
downloadgentoo-3fc84e7cb8eb0f4d7f22127b96f38241893a2c2e.tar.gz
gentoo-3fc84e7cb8eb0f4d7f22127b96f38241893a2c2e.tar.bz2
gentoo-3fc84e7cb8eb0f4d7f22127b96f38241893a2c2e.zip
dev-perl/IO-Compress-Brotli: fix unbundle patch for 0.17.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/IO-Compress-Brotli')
-rw-r--r--dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.17.0.ebuild2
-rw-r--r--dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.017-unbundle.patch55
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.17.0.ebuild b/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.17.0.ebuild
index 69dee213f563..11a2b12873d8 100644
--- a/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.17.0.ebuild
+++ b/dev-perl/IO-Compress-Brotli/IO-Compress-Brotli-0.17.0.ebuild
@@ -25,5 +25,5 @@ BDEPEND="${RDEPEND}
"
PATCHES=(
- "${FILESDIR}"/${PN}-0.010-unbundle.patch
+ "${FILESDIR}"/${PN}-0.017-unbundle.patch
)
diff --git a/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.017-unbundle.patch b/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.017-unbundle.patch
new file mode 100644
index 000000000000..d07e691840a7
--- /dev/null
+++ b/dev-perl/IO-Compress-Brotli/files/IO-Compress-Brotli-0.017-unbundle.patch
@@ -0,0 +1,55 @@
+From 59541041bc3b39e8539fd12a8e584a63040ad7a5 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Tue, 4 Feb 2020 23:17:49 +1300
+Subject: Disable using bundled brotli
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 57063cf..809001a 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,6 +1,5 @@
+ use 5.014000;
+ use ExtUtils::MakeMaker;
+-use Alien::cmake3;
+ use File::Spec::Functions qw/catfile/;
+ use Config;
+
+@@ -18,6 +17,12 @@ if ($Config{myuname} =~ /strawberry/i || $Config{osname} =~ /MSWin/i ) {
+ }
+ }
+
++my $bundled = $ENV{IO_COMPRESS_BROTLI_BUNDLED} || 0;
++
++# Avoid unnecessary dependency
++use if $bundled, 'Alien::cmake3';
++
++
+ WriteMakefile(
+ NAME => 'IO::Compress::Brotli',
+ VERSION_FROM => 'lib/IO/Compress/Brotli.pm',
+@@ -32,6 +37,7 @@ WriteMakefile(
+ 'Getopt::Long' => '0',
+ 'Time::HiRes' => '0',
+ },
++ ( $bundled ) ? (
+ CONFIGURE_REQUIRES => {
+ 'Alien::cmake3' => '0',
+ },
+@@ -41,6 +47,9 @@ WriteMakefile(
+ INC => '-Ibrotli/c/include',
+ MYEXTLIB => $myextlib,
+ clean => { FILES => "brotli/Makefile $myextlib brotli/CMakeCache.txt brotli/CMakeFiles/* brotli/CTestTestfile.cmake brotli/DartConfiguration.tcl brotli/brotli* brotli/cmake_install.cmake brotli/libbrotlicommon.pc brotli/libbrotlidec.pc brotli/libbrotlienc.pc" },
++ ) : (
++ LIBS => ['-lbrotlienc -lbrotlidec'],
++ ),
+ META_ADD => {
+ dynamic_config => 0,
+ resources => {
+@@ -50,6 +59,7 @@ WriteMakefile(
+ );
+
+ sub MY::postamble {
++ return '' unless $bundled;
+ my @dirs = Alien::cmake3->bin_dir;
+ my $cmake = defined $dirs[0] ? catfile($dirs[0] , Alien::cmake3->exe) : Alien::cmake3->exe;
+ '