summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-24 14:06:26 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-24 14:08:03 +1200
commit2bcf2e94fa0004cc69d41ea780a46c116279ed46 (patch)
tree91b94b428af178c00660a9a2c9c4b1545a093d05 /dev-perl/Data-UUID/Data-UUID-1.226.0.ebuild
parentwww-client/firefox: move fatal rust version check to pkg_setup (diff)
downloadgentoo-2bcf2e94fa0004cc69d41ea780a46c116279ed46.tar.gz
gentoo-2bcf2e94fa0004cc69d41ea780a46c116279ed46.tar.bz2
gentoo-2bcf2e94fa0004cc69d41ea780a46c116279ed46.zip
dev-perl/Data-UUID: Bump to version 1.226.0
- EAPI7 - Remove unwanted tests - Ensure CFLAGS passed to make/compiler - Remove unused/empty variable assignments Upstream: - Properly quote C-strings passed in DEFINE - Fix memory leak by decreasing reference count - Set umask before fopen in destructor Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Data-UUID/Data-UUID-1.226.0.ebuild')
-rw-r--r--dev-perl/Data-UUID/Data-UUID-1.226.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Data-UUID/Data-UUID-1.226.0.ebuild b/dev-perl/Data-UUID/Data-UUID-1.226.0.ebuild
new file mode 100644
index 000000000000..41e3783082da
--- /dev/null
+++ b/dev-perl/Data-UUID/Data-UUID-1.226.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=1.226
+inherit perl-module
+
+DESCRIPTION="Generate Globally/Universally Unique Identifiers (GUIDs/UUIDs)"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+PERL_RM_FILES=(
+ t/pod-coverage.t
+ t/pod.t
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}