summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-14 19:20:44 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-14 19:24:19 +0200
commitf7001551a9f24db3988bd51f720926f136f57cbd (patch)
tree2665cce5b08cff9a352d35e95fcec85abbf484d9 /dev-ml
parentdev-ml/ppx_custom_printf: add 0.17.0 (diff)
downloadgentoo-f7001551a9f24db3988bd51f720926f136f57cbd.tar.gz
gentoo-f7001551a9f24db3988bd51f720926f136f57cbd.tar.bz2
gentoo-f7001551a9f24db3988bd51f720926f136f57cbd.zip
dev-ml/bin_prot: add 0.17.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/bin_prot/Manifest1
-rw-r--r--dev-ml/bin_prot/bin_prot-0.17.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/bin_prot/Manifest b/dev-ml/bin_prot/Manifest
index d27a936f67e5..7d613a6dfd93 100644
--- a/dev-ml/bin_prot/Manifest
+++ b/dev-ml/bin_prot/Manifest
@@ -1,3 +1,4 @@
DIST bin_prot-0.14.0.tar.gz 342884 BLAKE2B 9210ca230d9f42ce3dd6ad18e66b62e41eafccf83ac632a988cdc36c16f273076ccdd67ece333acb70e2604180084811319ae41decbd7ef6bba0ee16538c0cae SHA512 7e7bec7dc5ec49b7bc099687a90840620529c36d552e8985b45f2f9a2437396c8b41583081b8c6a75bf3b14bb3ab4db9134cebd12f70f2345c8fa74e1b8fa252
DIST bin_prot-0.15.0.tar.gz 345362 BLAKE2B 654014d47cdf59374247bd904005972f60d24ee711da037fdfdfbd9d5318fcabbb5905df2ec7b401cadb9ce76fd5301917d3084002bae3fc61dc2debedab6024 SHA512 7adbb683ef09d9f3376cd8fff5d299c0d9cac350e14fbee5e2c9e038086e48c188bb115d0dc5701e82efc2076227a0656f49704cc8b783dc5a8d6c2a9735086b
DIST bin_prot-0.16.0.tar.gz 343886 BLAKE2B f13574daba74d813810afb844ebd300803279fb5ab0c067b64dc13230a0cf5d88b46809892465b7bea22e41696c962de40f5cb7c05099a98de7c01f0a7f96240 SHA512 e6e2b4c2984fc89fc7ceb57cae7b7f796e6a0441e4d37da1b6bc1f167d8900b1c4bc0174d5d9de5669b7539d9256293365242e9875ef78fccbda226635c63b5d
+DIST bin_prot-0.17.0.tar.gz 351860 BLAKE2B bad3203bc42f6f95550a29392fe419d3159614743736ee3bf5855765330c2549575d7af8d42f3534be37fb346d43aa56667d71af328c7ea8ba6c4a64006f695a SHA512 02047b9562e4bc6abd4c19afcbd236a05807e6fc704c8a27436a55c27e7ce2df7d928fa3616727ff71d2dc9b3c9c04d06b9e0337e90fc75dd83ae34b4a0abfbe
diff --git a/dev-ml/bin_prot/bin_prot-0.17.0.ebuild b/dev-ml/bin_prot/bin_prot-0.17.0.ebuild
new file mode 100644
index 000000000000..88b96d047140
--- /dev/null
+++ b/dev-ml/bin_prot/bin_prot-0.17.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Binary protocol generator"
+HOMEPAGE="https://github.com/janestreet/bin_prot"
+SRC_URI="https://github.com/janestreet/bin_prot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ dev-ml/ppx_base:${SLOT}[ocamlopt?]
+ dev-ml/ppx_compare:${SLOT}[ocamlopt?]
+ dev-ml/ppx_custom_printf:${SLOT}[ocamlopt?]
+ dev-ml/ppx_fields_conv:${SLOT}[ocamlopt?]
+ dev-ml/ppx_optcomp:${SLOT}[ocamlopt?]
+ dev-ml/ppx_sexp_conv:${SLOT}[ocamlopt?]
+ dev-ml/ppx_stable_witness:${SLOT}[ocamlopt?]
+ dev-ml/ppx_variants_conv:${SLOT}[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"