summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-14 19:18:43 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-14 19:23:41 +0200
commit9c42293457dbc37279f182915f6f3089f194804b (patch)
treeb6d6e3a233d9aa11cb607abebe2b8c8697cf4e55 /dev-ml
parentdev-ml/typerep: add 0.17.0 (diff)
downloadgentoo-9c42293457dbc37279f182915f6f3089f194804b.tar.gz
gentoo-9c42293457dbc37279f182915f6f3089f194804b.tar.bz2
gentoo-9c42293457dbc37279f182915f6f3089f194804b.zip
dev-ml/ppx_typerep_conv: add 0.17.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_typerep_conv/Manifest1
-rw-r--r--dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.17.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ppx_typerep_conv/Manifest b/dev-ml/ppx_typerep_conv/Manifest
index 506935e8cf2d..e9ee7e125dbc 100644
--- a/dev-ml/ppx_typerep_conv/Manifest
+++ b/dev-ml/ppx_typerep_conv/Manifest
@@ -2,3 +2,4 @@ DIST ppx_typerep_conv-0.14.1.tar.gz 9453 BLAKE2B 4acafdd51df0659746697283aa3240f
DIST ppx_typerep_conv-0.14.2.tar.gz 9474 BLAKE2B 7a7ff6669d9af2ced905e5b104058d26ffe06e3784af366a1a4ce753337eeb87c9bfe02d1a6fddaac6c387105d2583194cbd06b915eb35d16e06b1d4ab977e2f SHA512 9372f13cb3f62b3732af4f8ddc00314dd71869bab5599ae0a112d32669de300346781b7fcd2bd649ccedfde54fcd86fb6186812eeb528858048bcd9d5ad443dd
DIST ppx_typerep_conv-0.15.0.tar.gz 9392 BLAKE2B 3f7d9ac373048434ea55deab18b25bd74da77116b20db841c412c3304f318a1b820708c3f9cb6eab1f92fda399d3e6168fc8b3cc0546501f4fc6b57da5f74414 SHA512 3f5bb2c70674e5f6219daa883fe948023a60558c9560c5d8e6b187e0420adf8767ce4f5cca06fe7edccd52e531b2e79d962f7fdc7502cb63280c364627621c73
DIST ppx_typerep_conv-0.16.0.tar.gz 9421 BLAKE2B dbef20e205e550ab4ef16cf0e53bb47567b922297818a944a3fb6cd07eee90c6184d9cd33d7fc2e67b47fd371c95410f7022a8e140c9946c1c7502bb2a433d0c SHA512 842f3caeb22b7d1feb1de9f599ffe2474365704e7ce9c05366b9714bcbf165791eda8b16d420a3a64ccc8ea44a9b2178ffddaa8e3ad005c6536c3559f2da295a
+DIST ppx_typerep_conv-0.17.0.tar.gz 9462 BLAKE2B 61f7c0d203a0838874086023cfa94223e0388b0baff5c51d4074b88c4687ce6c55e663f309e8aec7ac49cec9dfd10407f3e8cc2c0c0dffe074ebcd8ac7309222 SHA512 9051905d3fd042f6f4bec5653c249f4a164b636b8f53db67d9a25bcf7b230befd1a0477b16c50f5d9c766bc52f3317a28a929fe8fc725514377925df7ce8da88
diff --git a/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.17.0.ebuild b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.17.0.ebuild
new file mode 100644
index 000000000000..f2a1a96bc6af
--- /dev/null
+++ b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.17.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Generation of runtime types from type declarations"
+HOMEPAGE="https://github.com/janestreet/ppx_typerep_conv"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ dev-ml/typerep:${SLOT}[ocamlopt?]
+ >=dev-ml/ppxlib-0.32.1:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"