summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-11-03 22:39:06 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-11-03 22:39:06 +0100
commit33f9cd3dcc8db810ca6a1fb7dafc3bc3637d6c33 (patch)
treeda0dd6bba64f02573182b3f0f01d3ce6a91411fd /dev-ml
parentdev-util/gn: bump to 0.1943, EAPI 8 (diff)
downloadgentoo-33f9cd3dcc8db810ca6a1fb7dafc3bc3637d6c33.tar.gz
gentoo-33f9cd3dcc8db810ca6a1fb7dafc3bc3637d6c33.tar.bz2
gentoo-33f9cd3dcc8db810ca6a1fb7dafc3bc3637d6c33.zip
dev-ml/fmt: bump 0.9.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/fmt/Manifest1
-rw-r--r--dev-ml/fmt/fmt-0.9.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/fmt/Manifest b/dev-ml/fmt/Manifest
index 8b6f6722529e..7199ca322bcc 100644
--- a/dev-ml/fmt/Manifest
+++ b/dev-ml/fmt/Manifest
@@ -1 +1,2 @@
DIST fmt-0.8.9.tbz 21469 BLAKE2B 4cddf626118c9bdea435f9db4e6a3c0b92b49b2c07d1b0f708ae7b82963453be666ad49df196d98b466236509d3fa5a519e191da6b2385a308d1019f1583f0b5 SHA512 19b97caf5d2dbe86cd75bec478707b8f4e4b899b2a11ce04790dc5acb5c9ed6ea98047de52ee50c6480231a16307af2541eabaa94d18d7d008f7a67496f5f626
+DIST fmt-0.9.0.tbz 22699 BLAKE2B 6c251b7c32093a5860b8e5c18f6a92573e664e8a20eb4b85dc6e601a04045d9c55c1e4a4f5cb879ccc92046c15c5ff97d1877ab78ecfaa2a4aa83a9f49fd409e SHA512 66cf4b8bb92232a091dfda5e94d1c178486a358cdc34b1eec516d48ea5acb6209c0dfcb416f0c516c50ddbddb3c94549a45e4a6d5c5fd1c81d3374dec823a83b
diff --git a/dev-ml/fmt/fmt-0.9.0.ebuild b/dev-ml/fmt/fmt-0.9.0.ebuild
new file mode 100644
index 000000000000..2c981562f8e6
--- /dev/null
+++ b/dev-ml/fmt/fmt-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib opam
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="https://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="https://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt]
+ >=dev-lang/ocaml-4.08:=[ocamlopt]
+ dev-ml/result:=[ocamlopt]
+ dev-ml/stdlib-shims:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-ml/topkg-0.9
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test _build/test/test.native || die
+}