summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-30 23:28:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-30 23:28:21 +0100
commitedb3042b5f05f0f54b68f2a95179a8f27580ff7a (patch)
tree37e7a7fa9fd75b1e9ba8217ba7d7f56e2cea5bc3 /dev-ml/ppx_here
parentdev-ml/textutils: bump to 113.33.03 (diff)
downloadgentoo-edb3042b5f05f0f54b68f2a95179a8f27580ff7a.tar.gz
gentoo-edb3042b5f05f0f54b68f2a95179a8f27580ff7a.tar.bz2
gentoo-edb3042b5f05f0f54b68f2a95179a8f27580ff7a.zip
dev-ml/ppx_here: bump to 113.33.03
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/ppx_here')
-rw-r--r--dev-ml/ppx_here/Manifest1
-rw-r--r--dev-ml/ppx_here/ppx_here-113.33.03.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/ppx_here/Manifest b/dev-ml/ppx_here/Manifest
index 2d19c0879dd4..9959053dcff7 100644
--- a/dev-ml/ppx_here/Manifest
+++ b/dev-ml/ppx_here/Manifest
@@ -1 +1,2 @@
DIST ppx_here-113.33.00.tar.gz 53046 SHA256 76ff5a098f6028a3d08e97fe6e2dca1125ad2727e839ced777cd73ffac47e9b4 SHA512 9b6be574dfc714a303106b53fd62639fe3ef50797fd0cbde3562ebb34693fc4bdb8ea49852e0e915379600f03c32603a9f4c3dd0f7e9a9552ed4df506fc5bb78 WHIRLPOOL caee170892c2de80dd80ad97bb3ee6ca39a8bc210558807227f3603b7b1e30d0c59b9b1835dd1d2f22052bb2910309ee2b7ab84440bda5e7699299cdfe7e8aa6
+DIST ppx_here-113.33.03.tar.gz 52064 SHA256 671bf487c5beaf0596fa4f9cf255aff28d89378004f2f9c58ae36110bba3c8ab SHA512 478e5638aaa6cd5ca28d3f4f85b94b5f98e2dec92c7c26dd7a35cd6df639a6e264f1983266352f927eac1cc7e960d65e1d37c2233ce5a96c125afe98da8b8e88 WHIRLPOOL 51f4abe23a5e25b04b554e69126c5d4481a95851f1d72c3ae0c68791d443270c8bb8a2879b95fc3206e608eb7394476239c931f4b7a02545a20f97693e603a43
diff --git a/dev-ml/ppx_here/ppx_here-113.33.03.ebuild b/dev-ml/ppx_here/ppx_here-113.33.03.ebuild
new file mode 100644
index 000000000000..e4ba60c39885
--- /dev/null
+++ b/dev-ml/ppx_here/ppx_here-113.33.03.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Expands [%here] into its location"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_core:="
+
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}