summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-07-02 08:20:20 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-07-02 09:21:31 +0200
commit87ee3cf78096b4d10eeff57183dc9a6021f250e7 (patch)
treeecb86d7367bf4ed77f4b49f4fd13c899d165e274 /dev-ml/ppx_bin_prot
parentdev-ml/bin_prot: add 0.16.0 (diff)
downloadgentoo-87ee3cf78096b4d10eeff57183dc9a6021f250e7.tar.gz
gentoo-87ee3cf78096b4d10eeff57183dc9a6021f250e7.tar.bz2
gentoo-87ee3cf78096b4d10eeff57183dc9a6021f250e7.zip
dev-ml/ppx_bin_prot: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_bin_prot')
-rw-r--r--dev-ml/ppx_bin_prot/Manifest1
-rw-r--r--dev-ml/ppx_bin_prot/ppx_bin_prot-0.16.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_bin_prot/Manifest b/dev-ml/ppx_bin_prot/Manifest
index 2438fb8a4604..f64024a7e876 100644
--- a/dev-ml/ppx_bin_prot/Manifest
+++ b/dev-ml/ppx_bin_prot/Manifest
@@ -1,2 +1,3 @@
DIST ppx_bin_prot-0.14.0.tar.gz 36642 BLAKE2B 6a80f574fad5e3ba2bb1adad8e6af86a9bd463ab7ed8976901234694a56f9e17c04ccc74f0bd4a18c75f1a4ccd81848218078bb387f8ff2f5df337c5f2492226 SHA512 7d61624d18fd76daed5a5d60d16ac0a3fd658ef650ee6ae4b65346e96d1718a044deb3ca6fbb63c69176505f64d0d1b6becd8419061cfb69466d45e16964329b
DIST ppx_bin_prot-0.15.0.tar.gz 37045 BLAKE2B 6ec039c1b18c759a676c1da30f02d70799e93d77dcd530844b2a448e4f2a58fbdf9c88f0d4a802a34070959586e7b9c7b1be1b51de9d29d34ea57fba9c7938cf SHA512 3fdc7e9431458b752d553f093762e3ed3c96af3a789eceeb94895284de961a887e358d137c21da372cadf6c0e6329628f6c698499581f672e0e1913b3274cc14
+DIST ppx_bin_prot-0.16.0.tar.gz 37632 BLAKE2B 48597b32da8b41dc5c9027d8dccff099055b9efdd7510c5f89c4d74f51e2fe6150e800ed5fbcc44f818deed5843e5bd485403ef7ec1e09ddec8d2b328e1dc8ad SHA512 b6e4f1a1ea1dfcfb2c23f34b0842097ad85535a22a767b2f47aa3a5812a112a60768c7b94bfce2602721f165b8ffec1e5282e83a008b2c6684bb102093467f3c
diff --git a/dev-ml/ppx_bin_prot/ppx_bin_prot-0.16.0.ebuild b/dev-ml/ppx_bin_prot/ppx_bin_prot-0.16.0.ebuild
new file mode 100644
index 000000000000..c8f350402be7
--- /dev/null
+++ b/dev-ml/ppx_bin_prot/ppx_bin_prot-0.16.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Generation of bin_prot readers and writers from types"
+HOMEPAGE="https://github.com/janestreet/ppx_bin_prot"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/bin_prot:${SLOT}
+ dev-ml/ppx_here:${SLOT}
+ >=dev-ml/ppxlib-0.28.0:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ml/ppx_jane
+ )"