summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-24 08:46:46 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-24 08:47:19 +0100
commitbaa79e3d7e06a1c155ba6d4cdc3e36c63885dd46 (patch)
tree40b5eec405720a425358a1eb52a378a5114def5e /dev-ml/ocaml-ctypes
parentmail-mta/postfix: add 3.7.4 (diff)
downloadgentoo-baa79e3d7e06a1c155ba6d4cdc3e36c63885dd46.tar.gz
gentoo-baa79e3d7e06a1c155ba6d4cdc3e36c63885dd46.tar.bz2
gentoo-baa79e3d7e06a1c155ba6d4cdc3e36c63885dd46.zip
dev-ml/ocaml-ctypes: fix shuffle
Closes: https://bugs.gentoo.org/882669 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-ctypes')
-rw-r--r--dev-ml/ocaml-ctypes/files/ocaml-ctypes-0.20.0-shuffle.patch13
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild4
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild4
3 files changed, 19 insertions, 2 deletions
diff --git a/dev-ml/ocaml-ctypes/files/ocaml-ctypes-0.20.0-shuffle.patch b/dev-ml/ocaml-ctypes/files/ocaml-ctypes-0.20.0-shuffle.patch
new file mode 100644
index 000000000000..51bad2efdd7c
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/files/ocaml-ctypes-0.20.0-shuffle.patch
@@ -0,0 +1,13 @@
+--- a/Makefile 2023-01-24 08:35:02.515456277 +0100
++++ b/Makefile 2023-01-24 08:35:45.459755298 +0100
+@@ -161,7 +161,9 @@
+ $(INSTALL_HEADERS) \
+ $(if $(filter yes,$($(PROJECT).install_native_objects)),$(NATIVE_OBJECTS)))
+
+-install: META-install $(PROJECTS:%=install-%)
++install:
++ $(MAKE) META-install
++ $(MAKE) $(PROJECTS:%=install-%)
+
+ uninstall:
+ $(OCAMLFIND) remove ctypes
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild
index a3fbc4c28994..46407af9f60c 100644
--- a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
test? ( dev-ml/ounit2 dev-ml/lwt )"
REQUIRED_USE="ocamlopt"
+PATCHES=( "${FILESDIR}"/${P}-shuffle.patch )
+
src_prepare() {
sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die
default
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild
index 3b3fce5d0eaf..78e08ed8b8f7 100644
--- a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
test? ( dev-ml/ounit2 dev-ml/lwt )"
REQUIRED_USE="ocamlopt"
+PATCHES=( "${FILESDIR}"/${PN}-0.20.0-shuffle.patch )
+
src_prepare() {
sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die
default