summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-27 19:47:37 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-27 20:48:03 +0100
commit0629f0d020517794dd9c128c1630387333f1ff01 (patch)
tree8179f407c477401d527194140a46f96c958f558c /dev-ml/cairo2/cairo2-0.6.4.ebuild
parentdev-ml/base: add 0.15.1 (diff)
downloadgentoo-0629f0d020517794dd9c128c1630387333f1ff01.tar.gz
gentoo-0629f0d020517794dd9c128c1630387333f1ff01.tar.bz2
gentoo-0629f0d020517794dd9c128c1630387333f1ff01.zip
dev-ml/cairo2: add 0.6.4
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/cairo2/cairo2-0.6.4.ebuild')
-rw-r--r--dev-ml/cairo2/cairo2-0.6.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/cairo2/cairo2-0.6.4.ebuild b/dev-ml/cairo2/cairo2-0.6.4.ebuild
new file mode 100644
index 000000000000..66f8aa4ef02f
--- /dev/null
+++ b/dev-ml/cairo2/cairo2-0.6.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Binding to Cairo, a 2D Vector Graphics Library"
+HOMEPAGE="https://github.com/Chris00/ocaml-cairo"
+SRC_URI="https://github.com/Chris00/ocaml-cairo/releases/download/${PV}/cairo2-${PV}.tbz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ x11-libs/cairo:=[svg(+)]
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+# >>> Test phase: dev-ml/cairo2-0.6.1
+# image_create alias tests/runtest (got signal SEGV)
+# (cd _build/default/tests && ./image_create.exe)
+# DESTROY bigarray 'data'
+# Done: 70/72 (jobs: 1) * ERROR: dev-ml/cairo2-0.6.1::x-portage failed (test phase):
+RESTRICT=test
+
+# Remove lablgtk2 dep https://github.com/Chris00/ocaml-cairo/issues/21
+# Fix compiler warnings, from: https://github.com/Chris00/ocaml-cairo/pull/22
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.1-ignore-gtk-and-pango.patch
+)