summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:20:30 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:39 +0100
commit5595b570cd5a267c8a7b04faa3ee75928b39bdbb (patch)
tree5df7f5c280f87a4d655a9702723d1ac94d7acfd5 /dev-lua
parentdev-lua/lua-term: update EAPI 7 -> 8 (diff)
downloadgentoo-5595b570cd5a267c8a7b04faa3ee75928b39bdbb.tar.gz
gentoo-5595b570cd5a267c8a7b04faa3ee75928b39bdbb.tar.bz2
gentoo-5595b570cd5a267c8a7b04faa3ee75928b39bdbb.zip
dev-lua/lua-term: drop 0.7-r101
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-term/lua-term-0.7-r101.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-lua/lua-term/lua-term-0.7-r101.ebuild b/dev-lua/lua-term/lua-term-0.7-r101.ebuild
deleted file mode 100644
index b095f582edc7..000000000000
--- a/dev-lua/lua-term/lua-term-0.7-r101.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-MY_PV="0.07"
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Terminal operations for Lua"
-HOMEPAGE="https://github.com/hoelzro/lua-term"
-SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="${LUA_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- sed -e 's/-O3//g' -i Makefile
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "CFLAGS=${CFLAGS} ${LDFLAGS} $(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}" all
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- LUA_LIBDIR="${ED}/$(lua_get_cmod_dir)/term"
- LUA_SHARE="${ED}/$(lua_get_lmod_dir)/term"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-}