summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-06-23 23:53:07 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-06-24 23:35:39 +0200
commit47094bf1274414455c6a444cea98699bd810e9d0 (patch)
treee6740bb546264ffd84c750d82769dedfb704b881 /dev-lua/luacheck
parentdev-libs/level-zero: add 1.12.0 (diff)
downloadgentoo-47094bf1274414455c6a444cea98699bd810e9d0.tar.gz
gentoo-47094bf1274414455c6a444cea98699bd810e9d0.tar.bz2
gentoo-47094bf1274414455c6a444cea98699bd810e9d0.zip
dev-lua/luacheck: add 1.1.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luacheck')
-rw-r--r--dev-lua/luacheck/Manifest1
-rw-r--r--dev-lua/luacheck/luacheck-1.1.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-lua/luacheck/Manifest b/dev-lua/luacheck/Manifest
index 4244f06164f4..29737d9cd06e 100644
--- a/dev-lua/luacheck/Manifest
+++ b/dev-lua/luacheck/Manifest
@@ -1 +1,2 @@
DIST luacheck-1.1.0.tar.gz 178588 BLAKE2B 9e1946cc3c88d7690d3cdb8e70be3dde1b863d1c55a6b5bef755715456671c13c862686f888098b878d10a2c1ec1b83ed6b26b01ebc884047c9908fa6bc2ead7 SHA512 aca1145b64070468ce8e3de1130f0cadba0dbef14ce61fef0a234ef5e890e69f1bd9dfebaa30c38a8e62405d08e1f0319748e00fc403ba093c5945ca438e0c40
+DIST luacheck-1.1.1.tar.gz 179107 BLAKE2B 48fb07d4d74206581054718c0b422a65b7de01d7e5f05cd9139f19a74bbe0fc0f98977e6b4c97e2d984db98e18a9fe7b3eefaf44b8ab71bf95f84a5c649e9ca6 SHA512 0294cfc49a8a6c1c2ee4d326fd85bf1c8040b6053ed68975d7aa65a33956d9ad8d715281efc319d54ad8f1b66888a0ff263da8d2ccaace16b51bac87d0fb86c7
diff --git a/dev-lua/luacheck/luacheck-1.1.1.ebuild b/dev-lua/luacheck/luacheck-1.1.1.ebuild
new file mode 100644
index 000000000000..dc87175879bb
--- /dev/null
+++ b/dev-lua/luacheck/luacheck-1.1.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua
+
+DESCRIPTION="A tool for linting and static analysis of Lua code"
+HOMEPAGE="https://github.com/lunarmodules/luacheck"
+SRC_URI="https://github.com/lunarmodules/luacheck/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lua/lua-argparse[${LUA_USEDEP}]
+ dev-lua/lua-utf8[${LUA_USEDEP}]
+ dev-lua/luafilesystem[${LUA_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-lua/busted[${LUA_USEDEP}]
+ dev-lua/lua_cliargs[${LUA_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.23.0-disable-measuring-performance-test.patch" )
+
+src_compile() {
+ if use doc; then
+ sphinx-build docsrc html || die
+ fi
+}
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins -r src/luacheck
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ newbin bin/luacheck.lua luacheck
+
+ use doc && local -a HTML_DOCS=( "html/." )
+ einstalldocs
+}