summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-09 09:58:44 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-09 09:58:44 +0200
commitd66f38dfbe00dcf62ac71843a08f95d9d4273231 (patch)
tree497fe358d55845c0f3c37756874babdf824a1e8e /dev-libs
parentdev-db/libiodbc: drop multilib (diff)
downloadgentoo-d66f38dfbe00dcf62ac71843a08f95d9d4273231.tar.gz
gentoo-d66f38dfbe00dcf62ac71843a08f95d9d4273231.tar.bz2
gentoo-d66f38dfbe00dcf62ac71843a08f95d9d4273231.zip
dev-libs/antlr-c: drop multilib, EAPI 8
No multilib reverse dependencies. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/antlr-c/antlr-c-3.5.2-r2.ebuild (renamed from dev-libs/antlr-c/antlr-c-3.5.2-r1.ebuild)27
1 files changed, 11 insertions, 16 deletions
diff --git a/dev-libs/antlr-c/antlr-c-3.5.2-r1.ebuild b/dev-libs/antlr-c/antlr-c-3.5.2-r2.ebuild
index e0b7a34e56fa..f7a8a0295cdd 100644
--- a/dev-libs/antlr-c/antlr-c-3.5.2-r1.ebuild
+++ b/dev-libs/antlr-c/antlr-c-3.5.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools multilib-minimal
+inherit autotools
MY_PN="${PN%-c}"
DESCRIPTION="The ANTLR3 C Runtime"
@@ -19,20 +19,16 @@ IUSE="debug debugger doc"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
PATCHES=( "${FILESDIR}/3.5-cflags.patch" )
-MULTILIB_WRAPPED_HEADERS=( /usr/include/antlr3config.h )
-DOCS=( AUTHORS ChangeLog NEWS README )
src_prepare() {
default
+
sed -i '/^QUIET/s/NO/YES/' doxyfile || die
eautoreconf
- multilib_copy_sources
}
-multilib_src_configure() {
+src_configure() {
local econfargs=(
- --enable-shared
- --disable-static
$(use_enable debug debuginfo)
$(use_enable debugger antlrdebug)
)
@@ -42,24 +38,23 @@ multilib_src_configure() {
*) econfargs+=( --disable-64bit ) ;;
esac
- econf "${econfargs[@]}"
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${econfargs[@]}"
}
src_compile() {
- multilib-minimal_src_compile
+ default
- if use doc; then
+ if use doc ; then
einfo "Generating API documentation ..."
- cd "${S}" || die
doxygen -u doxyfile || die
doxygen doxyfile || die
+
+ HTML_DOCS=( "${S}"/api/ )
fi
}
src_install() {
- use doc && HTML_DOCS=( "${S}/api/" )
-
- multilib-minimal_src_install
+ default
find "${ED}" -name '*.la' -delete || die
}