summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2016-01-11 22:12:54 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2016-01-11 22:13:29 +0100
commit41187308e0cbdbab20a61258a4a126b035afc6d7 (patch)
tree4aa469702b0f3517dd25e51a6063b606d2cd3afc /dev-libs
parentdev-vcs/git: Bump 2.6.x series. (diff)
downloadgentoo-41187308e0cbdbab20a61258a4a126b035afc6d7.tar.gz
gentoo-41187308e0cbdbab20a61258a4a126b035afc6d7.tar.bz2
gentoo-41187308e0cbdbab20a61258a4a126b035afc6d7.zip
dev-libs/btparser updated ebuild to version 0.26
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/btparser/Manifest1
-rw-r--r--dev-libs/btparser/btparser-0.26.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/btparser/Manifest b/dev-libs/btparser/Manifest
index 5f07106efaf6..e2010bc1af54 100644
--- a/dev-libs/btparser/Manifest
+++ b/dev-libs/btparser/Manifest
@@ -1,2 +1,3 @@
DIST btparser-0.24.tar.xz 353700 SHA256 9cc1e172c864afb6dec45850ed7b2fa605d39013918027df81800899ea654e32 SHA512 3aee4a8cbc8cda7017cc7203b670ba30443b5f302d728ecb7ce06a9569367543669c9c02d10a71b2bbf0bbc65cb927c0e25a53a422fc3be5e4a2ee51e5495198 WHIRLPOOL a5feb168f9ab2d4442c37ba388c0ed4708781ab2e6becc89ea20ac2601a698600e47721c0818aad8e4df93888cfadfdec68aace0f659985d95cecb31cdb01b8f
DIST btparser-0.25.tar.xz 355736 SHA256 afaad61a52d90c7dcc65f53485ced298e9cd9dab6a9ff611c4eb40bfcc2a786e SHA512 fc3f1f440fdf19eba8d698bdde9b1f197cbf663b7f8a53dea98c9fa6ffe4cd23a12b8d46d211fcff30dd4adbd3998723f7a2afb19c6c5d73da34156bc7877b56 WHIRLPOOL 5ed0fa3b7c97243d120c11d5870c4a682033501151df22bbf9a7b12832cecc888b3fad3ab6e0269c43835108af8bbd1b4ad3c81bb983b9bcd2ff55f2919257e1
+DIST btparser-0.26.tar.gz 564940 SHA256 4e6868ae52b836e0d3ce8d41f4fbc87626f476c1924133e13ce4075f50caaf31 SHA512 c5520f0aae3217482b97eac7c9cc5ae9be596df936ce958d84cb8e46a67c4b97a9184f9cd4bcab185d35c64f5ea98acd6cfb6f98512b9fa492a3aa9931d6668c WHIRLPOOL 6d29b40c1d2a46847af283922b585a8f5f16b2f6312df51ff6f62a8861e72922f477bdf636f8d228a02b60b1a9effe34413a68bee0e537874e91830a89329dc1
diff --git a/dev-libs/btparser/btparser-0.26.ebuild b/dev-libs/btparser/btparser-0.26.ebuild
new file mode 100644
index 000000000000..8361f569ae77
--- /dev/null
+++ b/dev-libs/btparser/btparser-0.26.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools gnome2 python-single-r1
+
+DESCRIPTION="Parser and analyzer for backtraces produced by GDB"
+HOMEPAGE="https://fedorahosted.org/btparser/"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static-libs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.21:2
+"
+DEPEND="${RDEPEND}"
+
+# Incomplete tarball for tests
+RESTRICT="test"
+
+src_prepare() {
+ eautoreconf # to prevent maintainer mode
+ gnome2_src_prepare
+}
+
+src_configure() {
+ export PYTHON_CFLAGS=$(python_get_CFLAGS)
+ export PYTHON_LIBS=$(python_get_LIBS)
+
+ gnome2_src_configure \
+ $(use_enable static-libs static)
+}