summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-04 00:31:18 +0100
committerSam James <sam@gentoo.org>2023-10-04 00:31:18 +0100
commitaee1ab708d843f9dcf7d7f173133db2c1299d3a8 (patch)
tree7d83aa846d4b559334f40477dd96efe6ae705d21 /dev-libs/pugixml
parentsys-apps/eza: add 0.14.0 (diff)
downloadgentoo-aee1ab708d843f9dcf7d7f173133db2c1299d3a8.tar.gz
gentoo-aee1ab708d843f9dcf7d7f173133db2c1299d3a8.tar.bz2
gentoo-aee1ab708d843f9dcf7d7f173133db2c1299d3a8.zip
dev-libs/pugixml: add 1.14
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/pugixml')
-rw-r--r--dev-libs/pugixml/Manifest1
-rw-r--r--dev-libs/pugixml/pugixml-1.14.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/pugixml/Manifest b/dev-libs/pugixml/Manifest
index 04cdfbf435e1..4c599e303ab7 100644
--- a/dev-libs/pugixml/Manifest
+++ b/dev-libs/pugixml/Manifest
@@ -1 +1,2 @@
DIST pugixml-1.13.tar.gz 573528 BLAKE2B 62b7233d46587a95936c809f06b5d5277ac0f79f125e1d02382f13ed5122d4f7d21d120b0e48049bffd1e2cc413160fd67f9258b1fc2cfccb7f9db8b9bce10c4 SHA512 5ff95a1ce06df01a72e736be4684c097dc656b2fc330b7fe6bf62601aca5c72edd0f40e51a643ce92f4fe5ba632b0b9fb57fbb1524aebcdd70441adeedec4a86
+DIST pugixml-1.14.tar.gz 576683 BLAKE2B 0379916979f796f5d0f4063d2b156159ec90915694c4b2fa93b14dad717709a2dd3dc2851f794e56fb8e35f47d39d1b9d84905a3f4b5b89a8e677af9d5a24f99 SHA512 730d203829eb24d6e1c873f9b921ae97cf7a157fd45504151bc2e61adea5c536eaf33ff38c5ad61629b54a6686135ff1834a61102b4660fbb9ead4ecf20dfd34
diff --git a/dev-libs/pugixml/pugixml-1.14.ebuild b/dev-libs/pugixml/pugixml-1.14.ebuild
new file mode 100644
index 000000000000..a2f872a9ebb0
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
+ inherit git-r3
+else
+ # Use non-release tarball for tests
+ # TODO: ask upstream to include tests in release tarballs?
+ SRC_URI="https://github.com/zeux/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -D${PN^^}_BUILD_TESTS=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}