summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-03 17:24:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-03 17:37:21 +0100
commitf4a6d15842cd05117e24f86d8bf1dd2ad4860fb1 (patch)
treeddb56d6073d1fe0fa9923e6a968098a6c53e7096 /dev-libs/plasma-wayland-protocols
parentmedia-libs/phonon-vlc: Use cmake.eclass and multibuild instead of ecm.eclass (diff)
downloadgentoo-f4a6d15842cd05117e24f86d8bf1dd2ad4860fb1.tar.gz
gentoo-f4a6d15842cd05117e24f86d8bf1dd2ad4860fb1.tar.bz2
gentoo-f4a6d15842cd05117e24f86d8bf1dd2ad4860fb1.zip
dev-libs/plasma-wayland-protocols: Use cmake instead of ecm.eclass
The latter was just overkill for the needs of this simple build system, this ensures that it works for Qt5/Qt6 "purity" builds alike. Closes: https://bugs.gentoo.org/923502 Closes: https://github.com/gentoo/kde/pull/980 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/plasma-wayland-protocols')
-rw-r--r--dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.12.0-r1.ebuild (renamed from dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.12.0.ebuild)21
1 files changed, 19 insertions, 2 deletions
diff --git a/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.12.0.ebuild b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.12.0-r1.ebuild
index 5a9c09e22f1e..ad0d538fed5b 100644
--- a/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.12.0.ebuild
+++ b/dev-libs/plasma-wayland-protocols/plasma-wayland-protocols-1.12.0-r1.ebuild
@@ -3,8 +3,7 @@
EAPI=8
-ECM_NONGUI=true
-inherit ecm kde.org
+inherit cmake kde.org
DESCRIPTION="Plasma Specific Protocols for Wayland"
HOMEPAGE="https://invent.kde.org/libraries/plasma-wayland-protocols"
@@ -16,3 +15,21 @@ fi
LICENSE="LGPL-2.1"
SLOT="0"
+
+BDEPEND="
+ dev-libs/libpcre2:*
+ >=kde-frameworks/extra-cmake-modules-5.115.0:*
+ || (
+ dev-qt/qtbase:6
+ dev-qt/qtcore:5
+ )
+"
+
+ecm_src_configure() {
+ local mycmakeargs=(
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON # ecm.eclass
+ -DKDE_INSTALL_DOCBUNDLEDIR="${EPREFIX}/usr/share/help" # ecm.eclass
+ )
+
+ cmake_src_configure
+}