summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-25 00:20:13 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-25 00:35:10 +0200
commit7b6c0d7a36f0dff1904de9753b61d1c83a79ff67 (patch)
tree0ddd3572e66b7a4cc24cec155131546e65332841 /dev-libs/opencl-clang
parentdev-util/spirv-llvm-translator: drop 12.0.0 (diff)
downloadgentoo-7b6c0d7a36f0dff1904de9753b61d1c83a79ff67.tar.gz
gentoo-7b6c0d7a36f0dff1904de9753b61d1c83a79ff67.tar.bz2
gentoo-7b6c0d7a36f0dff1904de9753b61d1c83a79ff67.zip
dev-libs/opencl-clang: drop multilib, EAPI 7 -> 8
Since no packages depend on multilib, we can drop it. Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/opencl-clang')
-rw-r--r--dev-libs/opencl-clang/opencl-clang-13.0.0-r1.ebuild (renamed from dev-libs/opencl-clang/opencl-clang-13.0.0.ebuild)20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-libs/opencl-clang/opencl-clang-13.0.0.ebuild b/dev-libs/opencl-clang/opencl-clang-13.0.0-r1.ebuild
index ae4242b3e576..a46a92527df9 100644
--- a/dev-libs/opencl-clang/opencl-clang-13.0.0.ebuild
+++ b/dev-libs/opencl-clang/opencl-clang-13.0.0-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-CMAKE_ECLASS=cmake
+LLVM_MAX_SLOT="13"
-inherit cmake-multilib llvm
+inherit cmake llvm
DESCRIPTION="OpenCL-oriented thin wrapper library around clang"
HOMEPAGE="https://github.com/intel/opencl-clang"
@@ -16,14 +16,13 @@ LICENSE="UoI-NCSA"
SLOT="13"
KEYWORDS="amd64"
-DEPEND="
- >=dev-util/spirv-llvm-translator-13.0.0:13=[${MULTILIB_USEDEP}]
- >=sys-devel/clang-13.0.0:13=[static-analyzer,${MULTILIB_USEDEP}]
- sys-devel/llvm:13=[${MULTILIB_USEDEP}]
+RDEPEND="
+ dev-util/spirv-llvm-translator:${SLOT}=
+ sys-devel/clang:${SLOT}=[static-analyzer]
+ sys-devel/llvm:${SLOT}=
"
-RDEPEND="${DEPEND}"
-LLVM_MAX_SLOT=13
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-8.0.0-clang_library_dir.patch
@@ -31,10 +30,11 @@ PATCHES=(
"${FILESDIR}"/${PN}-13.0.0_version.patch
)
-multilib_src_configure() {
+src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix ${LLVM_MAX_SLOT})"
-DCLANG_LIBRARY_DIRS="${EPREFIX}"/usr/lib/clang
)
+
cmake_src_configure
}