summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/mathjax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/mathjax')
-rw-r--r--dev-libs/mathjax/Manifest3
-rw-r--r--dev-libs/mathjax/mathjax-2.1.ebuild55
-rw-r--r--dev-libs/mathjax/mathjax-2.2.ebuild55
-rw-r--r--dev-libs/mathjax/mathjax-2.4.ebuild55
-rw-r--r--dev-libs/mathjax/metadata.xml23
5 files changed, 191 insertions, 0 deletions
diff --git a/dev-libs/mathjax/Manifest b/dev-libs/mathjax/Manifest
new file mode 100644
index 000000000000..dda9cac6e8fb
--- /dev/null
+++ b/dev-libs/mathjax/Manifest
@@ -0,0 +1,3 @@
+DIST mathjax-2.1.tar.gz 8834936 SHA256 f1a1aaa8b91ad5c749b3767ebd75294a7c305646f320d106899e2ea9227613d6 SHA512 b90399df7e06a77250fc76d9fd2de0c53c781e5897b85a01cf3a4ec033deea479e15d7d20ddad2730444d786fb6814ee88b5553ab89d7143fbf8f5b1b27fc330 WHIRLPOOL 499421b90f55ea34e379e3aa79fb37ef10c5704a8f019a775c59ff62172ee2de98e7a20576681b4976778117ca811eab221fa0d1af0dab9de86b0b712c41a323
+DIST mathjax-2.2.tar.gz 8974100 SHA256 7879b59d2992bc31cda0d8b9d4f8fb47d4435f3129e421be46cc6d3136ed7449 SHA512 11987a959a7b154ea8df4ad93ce6193eed930affcfbfd2ba3fd965356c3ea957ef73a3ea6830a841bbe81f64ed0d9a78ab9fd74d0cbf011671b7d174cdc1f80c WHIRLPOOL 5bfba913fe1d768561c52154b714791afd8721673c2b404e3f4dd2b0c18855843521baf6ac534bb07826d475f83e81b4131e218d2e359f329b9cc8f143e40899
+DIST mathjax-2.4.tar.gz 23048619 SHA256 f1450bafe63599729df7a879e40127f29cfc265abc4a0626bf9d274ed261cbeb SHA512 ee1662b3253fc77aa05d718b215c25b09cd28c0ac4a192537f9965b685452855439e192f0a816a7a1046b721cfa66558c5d4a1a1972db2ea351f2b9c71f24df0 WHIRLPOOL a1e68cfe968a2f36e3e693f0a03351d6c2bb8019f2b20975d6c4805839fb24793f31a12aebe68acabbada3dbf2c54f8da17641ead0451a122fd8e584700f11f6
diff --git a/dev-libs/mathjax/mathjax-2.1.ebuild b/dev-libs/mathjax/mathjax-2.1.ebuild
new file mode 100644
index 000000000000..adcf7408d480
--- /dev/null
+++ b/dev-libs/mathjax/mathjax-2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
+HOMEPAGE="http://www.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RESTRICT="binchecks"
+
+S=${WORKDIR}/MathJax-${PV}
+
+make_webconf() {
+ # web server config file - should we really do this?
+ cat > $1 <<-EOF
+ Alias /MathJax/ ${EPREFIX}${webinstalldir}/
+ Alias /mathjax/ ${EPREFIX}${webinstalldir}/
+
+ <Directory ${EPREFIX}${webinstalldir}>
+ Options None
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ </Directory>
+ EOF
+}
+
+src_prepare() {
+ find . -name .gitignore -delete || die
+}
+
+src_install() {
+ dodoc README*
+ use doc && dohtml -r docs/html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r test/*
+ fi
+ rm -rf test docs LICENSE README* || die
+
+ webinstalldir=/usr/share/${PN}
+ insinto ${webinstalldir}
+ doins -r *
+
+ make_webconf MathJax.conf
+ insinto /etc/httpd/conf.d
+ doins MathJax.conf
+}
diff --git a/dev-libs/mathjax/mathjax-2.2.ebuild b/dev-libs/mathjax/mathjax-2.2.ebuild
new file mode 100644
index 000000000000..5334ef6374fa
--- /dev/null
+++ b/dev-libs/mathjax/mathjax-2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
+HOMEPAGE="http://www.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RESTRICT="binchecks"
+
+S=${WORKDIR}/MathJax-${PV}
+
+make_webconf() {
+ # web server config file - should we really do this?
+ cat > $1 <<-EOF
+ Alias /MathJax/ ${EPREFIX}${webinstalldir}/
+ Alias /mathjax/ ${EPREFIX}${webinstalldir}/
+
+ <Directory ${EPREFIX}${webinstalldir}>
+ Options None
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ </Directory>
+ EOF
+}
+
+src_prepare() {
+ find . -name .gitignore -delete || die
+}
+
+src_install() {
+ dodoc README*
+ use doc && dohtml -r docs/html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r test/*
+ fi
+ rm -rf test docs LICENSE README* || die
+
+ webinstalldir=/usr/share/${PN}
+ insinto ${webinstalldir}
+ doins -r *
+
+ make_webconf MathJax.conf
+ insinto /etc/httpd/conf.d
+ doins MathJax.conf
+}
diff --git a/dev-libs/mathjax/mathjax-2.4.ebuild b/dev-libs/mathjax/mathjax-2.4.ebuild
new file mode 100644
index 000000000000..a4ff2ef3aff3
--- /dev/null
+++ b/dev-libs/mathjax/mathjax-2.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="JavaScript display engine for LaTeX, MathML and AsciiMath"
+HOMEPAGE="http://www.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax/archive/v${PV}-latest.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RESTRICT="binchecks"
+
+S=${WORKDIR}/MathJax-${PV}-latest
+
+make_webconf() {
+ # web server config file - should we really do this?
+ cat > $1 <<-EOF
+ Alias /MathJax/ ${EPREFIX}${webinstalldir}/
+ Alias /mathjax/ ${EPREFIX}${webinstalldir}/
+
+ <Directory ${EPREFIX}${webinstalldir}>
+ Options None
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ </Directory>
+ EOF
+}
+
+src_prepare() {
+ find . -name .gitignore -delete || die
+}
+
+src_install() {
+ dodoc README*
+ use doc && dohtml -r docs/html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r test/*
+ fi
+ rm -rf test docs LICENSE README* || die
+
+ webinstalldir=/usr/share/${PN}
+ insinto ${webinstalldir}
+ doins -r *
+
+ make_webconf MathJax.conf
+ insinto /etc/httpd/conf.d
+ doins MathJax.conf
+}
diff --git a/dev-libs/mathjax/metadata.xml b/dev-libs/mathjax/metadata.xml
new file mode 100644
index 000000000000..aad9ffd3c2ae
--- /dev/null
+++ b/dev-libs/mathjax/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <longdescription lang="en">
+ MathJax is an open-source JavaScript display engine for LaTeX and
+ MathML that works in all modern browsers. It was designed with the
+ goal of consolidating the recent advances in web technologies into a
+ single, definitive, math-on-the-web platform supporting the major
+ browsers and operating systems. It requires no setup on the part of
+ the user (no plugins to downlaod or software to install), so the
+ page author can write web documents that include mathematics and be
+ confident that users will be able to view it naturally and
+ easily. One simply includes MathJax and some mathematics in a web
+ page, and MathJax does the rest.
+</longdescription>
+ <upstream>
+ <remote-id type="github">mathjax/MathJax</remote-id>
+ </upstream>
+</pkgmetadata>