summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-04-10 23:35:25 -0400
committerCraig Andrews <candrews@gentoo.org>2020-04-11 15:58:51 -0400
commit349db05f3142a248f8db6b2d8bfb5e739bbfcb79 (patch)
tree977e6ca089831b34036208ae62d5d6e62680152b /dev-libs/libudfread/libudfread-9999.ebuild
parentsys-libs/libxcrypt-4.4.16: version bump (diff)
downloadgentoo-349db05f3142a248f8db6b2d8bfb5e739bbfcb79.tar.gz
gentoo-349db05f3142a248f8db6b2d8bfb5e739bbfcb79.tar.bz2
gentoo-349db05f3142a248f8db6b2d8bfb5e739bbfcb79.zip
dev-libs/libudfread: Read UDF from raw devices and image files
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/libudfread/libudfread-9999.ebuild')
-rw-r--r--dev-libs/libudfread/libudfread-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libudfread/libudfread-9999.ebuild b/dev-libs/libudfread/libudfread-9999.ebuild
new file mode 100644
index 000000000000..b3304062e6a9
--- /dev/null
+++ b/dev-libs/libudfread/libudfread-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://code.videolan.org/videolan/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://code.videolan.org/videolan/libudfread/-/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Library for reading UDF from raw devices and image files"
+HOMEPAGE="https://code.videolan.org/videolan/libudfread/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}