summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libflatarray
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libflatarray')
-rw-r--r--dev-libs/libflatarray/Manifest1
-rw-r--r--dev-libs/libflatarray/libflatarray-0.1.1.ebuild49
-rw-r--r--dev-libs/libflatarray/metadata.xml18
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/libflatarray/Manifest b/dev-libs/libflatarray/Manifest
new file mode 100644
index 000000000000..9de59f0da356
--- /dev/null
+++ b/dev-libs/libflatarray/Manifest
@@ -0,0 +1 @@
+DIST libflatarray-0.1.1.tar.bz2 16866 SHA256 3287f0ab1e670f3a2c43dd42de6399a8f853453f228e45076339ec31ea68cb56 SHA512 feed796e3932fc0131634f2f83415372e8046ee137502614de5bfb5af88db2fc44afcdd995d9b2f245737d223b79fdae33ba772b154b4dac064eeed67d489542 WHIRLPOOL ab8089f8f6023c23db9edc5b3bd5b7a6b69f291d02268122bdd2b08e24285af2967ac237afa826a727b3a9cdfe1c59b34d8f77517cb7478ae343f28edc3792a4
diff --git a/dev-libs/libflatarray/libflatarray-0.1.1.ebuild b/dev-libs/libflatarray/libflatarray-0.1.1.ebuild
new file mode 100644
index 000000000000..a57b8ecc986b
--- /dev/null
+++ b/dev-libs/libflatarray/libflatarray-0.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils cuda
+
+SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="Struct of arrays library with object oriented interface for C++"
+HOMEPAGE="http://www.libgeodecomp.org/libflatarray.html"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+IUSE="cuda doc"
+
+RDEPEND="
+ >=dev-libs/boost-1.48"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ cuda? ( dev-util/nvidia-cuda-toolkit )"
+
+src_prepare() {
+ if use cuda; then
+ cuda_src_prepare
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with cuda CUDA)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS=( README )
+ cmake-utils_src_install
+}
+
+src_test() {
+ cmake-utils_src_make test
+}
diff --git a/dev-libs/libflatarray/metadata.xml b/dev-libs/libflatarray/metadata.xml
new file mode 100644
index 000000000000..48fdd5b96474
--- /dev/null
+++ b/dev-libs/libflatarray/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ LibFlatArray is a multi-dimensional C++ array class which provides
+ an object-oriented view (a.k.a. array of structs, AoS) while
+ internally storing data in a struct of arrays (SoA) manner. It
+ comes with utilities to move data to CUDA enabled GPUs.
+ </longdescription>
+ <use>
+ <flag name="cuda">
+ Enables plugins for NVIDIA GPUs (e.g. CUDAAllocator)
+ </flag>
+ </use>
+</pkgmetadata>