summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-16 05:33:56 +0100
committerSam James <sam@gentoo.org>2024-10-16 05:33:56 +0100
commit8877c3aee662f72b1282296eb9e1cd2eab044e4d (patch)
tree2e57d2ac68ed7313fbde807f56ffb73048405cd3 /dev-libs/libffi
parentdev-libs/libffi: backport test fixes (diff)
downloadgentoo-8877c3aee662f72b1282296eb9e1cd2eab044e4d.tar.gz
gentoo-8877c3aee662f72b1282296eb9e1cd2eab044e4d.tar.bz2
gentoo-8877c3aee662f72b1282296eb9e1cd2eab044e4d.zip
dev-libs/libffi: drop 3.4.6-r1
Just use -r2 instead. See 662133e23b6925c1d1adf830f3650a9ddabb92de for -r1 vs -r2 and we need 1074f63fc8c1341b01c09c32c4855beb1a9dac67 anyway. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libffi')
-rw-r--r--dev-libs/libffi/libffi-3.4.6-r1.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/dev-libs/libffi/libffi-3.4.6-r1.ebuild b/dev-libs/libffi/libffi-3.4.6-r1.ebuild
deleted file mode 100644
index 4be465e7e37e..000000000000
--- a/dev-libs/libffi/libffi-3.4.6-r1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib-minimal preserve-libs
-
-MY_PV=${PV/_rc/-rc}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Portable, high level programming interface to various calling conventions"
-HOMEPAGE="https://sourceware.org/libffi/"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/libffi/libffi"
- inherit git-r3
-else
- SRC_URI="https://github.com/libffi/libffi/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-fi
-
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-# This is a core package which is depended on by e.g. Python.
-# Please use preserve-libs.eclass in pkg_{pre,post}inst to cover users
-# with FEATURES="-preserved-libs" or another package manager if SONAME changes.
-SLOT="0/8" # SONAME=libffi.so.8
-IUSE="debug exec-static-trampoline pax-kernel static-libs test"
-
-RESTRICT="!test? ( test )"
-BDEPEND="test? ( dev-util/dejagnu )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-arm64-cfi.patch
- "${FILESDIR}"/${P}-sparc-struct-targs.patch
- "${FILESDIR}"/${P}-test-typo.patch
- "${FILESDIR}"/${P}-x86-sse.patch
-)
-
-src_prepare() {
- default
-
- if [[ ${CHOST} == arm64-*-darwin* ]] ; then
- # ensure we use aarch64 asm, not x86 on arm64
- sed -i -e 's/aarch64\*-\*-\*/arm64*-*-*|&/' \
- configure configure.host || die
- fi
-}
-
-multilib_src_configure() {
- # --includedir= path maintains a few properties:
- # 1. have stable name across libffi versions: some packages like
- # dev-lang/ghc or kde-frameworks/networkmanager-qt embed
- # ${includedir} at build-time. Don't require those to be
- # rebuilt unless SONAME changes. bug #695788
- #
- # We use /usr/.../${PN} (instead of former /usr/.../${P}).
- #
- # 2. have ${ABI}-specific location as ffi.h is target-dependent.
- #
- # We use /usr/$(get_libdir)/... to have ABI identifier.
- ECONF_SOURCE="${S}" econf \
- --includedir="${EPREFIX}"/usr/$(get_libdir)/${PN}/include \
- --disable-multi-os-directory \
- $(use_enable static-libs static) \
- $(use_enable exec-static-trampoline exec-static-tramp) \
- $(use_enable pax-kernel pax_emutramp) \
- $(use_enable debug)
-}
-
-multilib_src_test() {
- emake -Onone check
-}
-
-multilib_src_install_all() {
- einstalldocs
- find "${ED}" -name "*.la" -delete || die
-}
-
-pkg_preinst() {
- preserve_old_lib /usr/$(get_libdir)/libffi.so.7
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /usr/$(get_libdir)/libffi.so.7
-}