summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-02 17:28:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-02 17:31:10 +0200
commit7a53b860cee8ca010d2fdbc65262a035c296276c (patch)
tree2988c89d72dca0b62d659e39d49fdfd3b2eaca13 /dev-libs/libclc
parentdev-db/postgis: add 3.1.9, 3.2.5, 3.3.3 (diff)
downloadgentoo-7a53b860cee8ca010d2fdbc65262a035c296276c.tar.gz
gentoo-7a53b860cee8ca010d2fdbc65262a035c296276c.tar.bz2
gentoo-7a53b860cee8ca010d2fdbc65262a035c296276c.zip
dev-libs/libclc: Remove old snapshot
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libclc')
-rw-r--r--dev-libs/libclc/Manifest1
-rw-r--r--dev-libs/libclc/libclc-17.0.0_pre20230520.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/dev-libs/libclc/Manifest b/dev-libs/libclc/Manifest
index d616caaf795e..a4f891667b74 100644
--- a/dev-libs/libclc/Manifest
+++ b/dev-libs/libclc/Manifest
@@ -7,4 +7,3 @@ DIST llvm-project-16.0.3.src.tar.xz.sig 566 BLAKE2B bbd96268b006fecffd7402452ae7
DIST llvm-project-16.0.4.src.tar.xz 117996332 BLAKE2B 2ea3ef25290ce6180d271e42fbf5e02da973a21e3929c1ac8d1e3e7b268d39db97611e15654ca7e6527add24542d0eed0ee2b1b9d85dfd0ba661e55356bac5d3 SHA512 860bcb999005f55bed25691304983d7bf707f8e3246000595b412b9e88f4a1614be0adb43bbff9c30f49b969373fa0becab02a56ac37915a5f83c52ca8ea3f95
DIST llvm-project-16.0.4.src.tar.xz.sig 566 BLAKE2B 43cb2147f12f98f864797158e8efcfed9c6780fae3b5c71c0f1aea19a4131ee91c36bdf5b10e44f478f2370c8d22a9038038ecd607f25a95f2d3e33628eb9ac0 SHA512 c902d1b652e6e144fcf74f550539f56665475b6bdf673ba5bf2f1731c3bb8f5717ed56433d488c54bbf2f429b432da84e0bfb4b5fb5f2b7fa208b4f24f682be7
DIST llvm-project-a2684acfb61d40f441e240035d7f1ba50da637c8.tar.gz 184900914 BLAKE2B fb1f836738415a640bc84283722f6a7355a06bc8ac05b544dd4ad4ac9552dcf70040b82b0493c5b4485b28610412279ec0adcf467e71915167aa7d010c08216e SHA512 c08ff8abc166399e692d3166ccf65eb4b647893cba8ffc10bcda815bc914a944855bac036d6349f6d820a6ff43d5417170e6ff8620d97a2a144a0898e95d09e3
-DIST llvm-project-abbb22cc0c9c33dedb8d53c2bd3e703f92baace7.tar.gz 183193919 BLAKE2B 75c63d39918f7ec0faca0b1d03ba17dbd7d39a6f1d3a031dcb005ae1729933d8481f0bd745ec029ab21779525b2ddaf2989eaca2aed2b0e9b60c50ef71c7fc11 SHA512 f0c1b6fe2e087db202d32de05613b7570bd9a82dfef2e464014c9d4c9ba02c20d423cb783aa40ce5e9c9e074288efb2e5b6d70d55913bd285108e747400f55e7
diff --git a/dev-libs/libclc/libclc-17.0.0_pre20230520.ebuild b/dev-libs/libclc/libclc-17.0.0_pre20230520.ebuild
deleted file mode 100644
index 5c4da7c66833..000000000000
--- a/dev-libs/libclc/libclc-17.0.0_pre20230520.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake llvm llvm.org python-any-r1
-
-DESCRIPTION="OpenCL C library"
-HOMEPAGE="https://libclc.llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions || ( MIT BSD )"
-SLOT="0"
-KEYWORDS=""
-IUSE="+spirv video_cards_nvidia video_cards_r600 video_cards_radeonsi"
-
-LLVM_MAX_SLOT=17
-BDEPEND="
- ${PYTHON_DEPS}
- || (
- (
- sys-devel/clang:17
- spirv? ( dev-util/spirv-llvm-translator:17 )
- )
- (
- sys-devel/clang:16
- spirv? ( dev-util/spirv-llvm-translator:16 )
- )
- (
- sys-devel/clang:15
- spirv? ( dev-util/spirv-llvm-translator:15 )
- )
- (
- sys-devel/clang:14
- spirv? ( dev-util/spirv-llvm-translator:14 )
- )
- (
- sys-devel/clang:13
- spirv? ( dev-util/spirv-llvm-translator:13 )
- )
- )
-"
-
-LLVM_COMPONENTS=( libclc )
-llvm.org_set_globals
-
-llvm_check_deps() {
- if use spirv; then
- has_version -b "dev-util/spirv-llvm-translator:${LLVM_SLOT}" ||
- return 1
- fi
- has_version -b "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- local libclc_targets=()
-
- use spirv && libclc_targets+=(
- "spirv-mesa3d-"
- "spirv64-mesa3d-"
- )
- use video_cards_nvidia && libclc_targets+=(
- "nvptx--"
- "nvptx64--"
- "nvptx--nvidiacl"
- "nvptx64--nvidiacl"
- )
- use video_cards_r600 && libclc_targets+=(
- "r600--"
- )
- use video_cards_radeonsi && libclc_targets+=(
- "amdgcn--"
- "amdgcn-mesa-mesa3d"
- "amdgcn--amdhsa"
- )
- [[ ${#libclc_targets[@]} ]] || die "libclc target missing!"
-
- libclc_targets=${libclc_targets[*]}
- local mycmakeargs=(
- -DLIBCLC_TARGETS_TO_BUILD="${libclc_targets// /;}"
- )
- cmake_src_configure
-}