summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKostadin Shishmanov <kocelfc@tutanota.com>2024-11-28 19:53:14 +0200
committerDaniel Pielmeier <billie@gentoo.org>2024-11-28 21:09:54 +0100
commit1f82b9883f79ee780a6844e9b4bd6736877a2de7 (patch)
tree0b1b0f4a73846a1bc72a26fe531f89c11c8a5c4c /dev-libs/libburn
parentdev-ml/typerep: add 0.17.1 (diff)
downloadgentoo-1f82b9883f79ee780a6844e9b4bd6736877a2de7.tar.gz
gentoo-1f82b9883f79ee780a6844e9b4bd6736877a2de7.tar.bz2
gentoo-1f82b9883f79ee780a6844e9b4bd6736877a2de7.zip
dev-libs/libburn: fix C23 compat
Backport upstream patch [1] to fix building with gcc 15. [1] https://dev.lovelyhq.com/libburnia/libburn/commit/d537f9dd35 Bug: https://bugs.gentoo.org/943701 Signed-off-by: Kostadin Shishmanov <kocelfc@tutanota.com> Closes: https://github.com/gentoo/gentoo/pull/39506 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'dev-libs/libburn')
-rw-r--r--dev-libs/libburn/files/libburn-1.5.6-c23.patch26
-rw-r--r--dev-libs/libburn/libburn-1.5.6-r1.ebuild9
2 files changed, 31 insertions, 4 deletions
diff --git a/dev-libs/libburn/files/libburn-1.5.6-c23.patch b/dev-libs/libburn/files/libburn-1.5.6-c23.patch
new file mode 100644
index 000000000000..c324e25ed6ef
--- /dev/null
+++ b/dev-libs/libburn/files/libburn-1.5.6-c23.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/943701
+https://dev.lovelyhq.com/libburnia/libburn/commit/d537f9dd35282df834a311ead5f113af67d223b3
+
+From d537f9dd35282df834a311ead5f113af67d223b3 Mon Sep 17 00:00:00 2001
+From: Thomas Schmitt <scdbackup@gmx.net>
+Date: Tue, 26 Nov 2024 23:02:03 +0100
+Subject: [PATCH] Bug fix: Faulty signal handler prototype spoiled compilation
+ under C23
+
+---
+ test/poll.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/poll.c b/test/poll.c
+index 660f384..cd5ff90 100644
+--- a/test/poll.c
++++ b/test/poll.c
+@@ -14,7 +14,7 @@ static struct burn_drive_info *drives;
+ static unsigned int n_drives;
+ int NEXT;
+
+-static void catch_int ()
++static void catch_int (int signum)
+ {
+ NEXT = 1;
+ }
diff --git a/dev-libs/libburn/libburn-1.5.6-r1.ebuild b/dev-libs/libburn/libburn-1.5.6-r1.ebuild
index caa8712f3c7b..b184b5fcda08 100644
--- a/dev-libs/libburn/libburn-1.5.6-r1.ebuild
+++ b/dev-libs/libburn/libburn-1.5.6-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools flag-o-matic
+inherit autotools
DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
HOMEPAGE="https://dev.lovelyhq.com/libburnia/web/wiki/Libburn"
@@ -21,6 +21,10 @@ DEPEND="
${RDEPEND}
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.6-c23.patch
+)
+
src_prepare() {
default
@@ -29,9 +33,6 @@ src_prepare() {
}
src_configure() {
- # bug #943701
- append-cflags -std=gnu17
-
econf \
$(use_enable static-libs static) \
--disable-ldconfig-at-install \