summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-09 14:42:21 +0100
committerSam James <sam@gentoo.org>2023-05-09 14:43:39 +0100
commit6d35e642cd7c454256eb22759ac1afe28a0c38ef (patch)
treec6f4e0242ce991ae7b6d67133de83c88ab7bd82d /dev-libs/libbsd
parentnet-p2p/syncthing: drop 1.23.2 (diff)
downloadgentoo-6d35e642cd7c454256eb22759ac1afe28a0c38ef.tar.gz
gentoo-6d35e642cd7c454256eb22759ac1afe28a0c38ef.tar.bz2
gentoo-6d35e642cd7c454256eb22759ac1afe28a0c38ef.zip
dev-libs/libbsd: fix build w/ musl-1.2.4
Closes: https://bugs.gentoo.org/905912 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/files/libbsd-0.11.7-musl-lfs.patch32
-rw-r--r--dev-libs/libbsd/libbsd-0.11.7-r2.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libbsd/files/libbsd-0.11.7-musl-lfs.patch b/dev-libs/libbsd/files/libbsd-0.11.7-musl-lfs.patch
new file mode 100644
index 000000000000..41cc27e75237
--- /dev/null
+++ b/dev-libs/libbsd/files/libbsd-0.11.7-musl-lfs.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/905912
+https://gitlab.freedesktop.org/libbsd/libbsd/-/merge_requests/24
+
+From c36c29f014b0ef56a3aef984fa40b0e100b6f419 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 15 Dec 2022 09:02:22 -0800
+Subject: [PATCH] funopen: Replace off64_t with off_t in funopen_seek
+
+AC_SYS_LARGEFILE in configure.ac is setting needed defines to make
+64bit off_t on relevant platforms.
+
+Fixes build on musl
+
+| ../../../../../../../../workspace/sources/libbsd/src/funopen.c:68:28: error: unknown type name 'off64_t'; did you mean 'off_t'?
+| funopen_seek(void *cookie, off64_t *offset, int whence)
+| ^~~~~~~
+| off_t
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/funopen.c
++++ b/src/funopen.c
+@@ -65,7 +65,7 @@ funopen_write(void *cookie, const char *buf, size_t size)
+ }
+
+ static int
+-funopen_seek(void *cookie, off64_t *offset, int whence)
++funopen_seek(void *cookie, off_t *offset, int whence)
+ {
+ struct funopen_cookie *cookiewrap = cookie;
+ off_t soff = *offset;
+--
+GitLab
diff --git a/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild b/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild
index 1383b676c74a..cc3316c69e98 100644
--- a/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild
+++ b/dev-libs/libbsd/libbsd-0.11.7-r2.ebuild
@@ -24,6 +24,7 @@ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-guillemjover )"
PATCHES=(
"${FILESDIR}/libbsd-build-Fix-version-script-linker-support-detection.patch"
+ "${FILESDIR}/libbsd-0.11.7-musl-lfs.patch"
)
src_prepare() {