summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-11 09:04:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-11 17:59:10 +0200
commit51f64b92683d487d70ae57c0a6befa71ef29d018 (patch)
treeeba3483ec8c91e688ee088106624aa810259a897 /dev-libs/kopeninghours
parentapp-office/kalendar: 23.04.1 version bump (diff)
downloadgentoo-51f64b92683d487d70ae57c0a6befa71ef29d018.tar.gz
gentoo-51f64b92683d487d70ae57c0a6befa71ef29d018.tar.bz2
gentoo-51f64b92683d487d70ae57c0a6befa71ef29d018.zip
dev-libs/kopeninghours: 23.04.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kopeninghours')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-23.04.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index ca46bc95b926..acbd86cfc618 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1,2 +1,3 @@
DIST kopeninghours-22.12.3.tar.xz 71072 BLAKE2B f86ca120035da5eb01736ea6dd5e35ed6f961a0d5cfe7af4b8d13b4a00b80b3252a39996efdb039a10a1e5d44fc33a57133ac5c75444d866e5f8a6c2e778e2ed SHA512 c8f87eb7398f8aff8de74b86dbc33fd50d90485dca4fb1e8bd87d4d697bb9f3670bca7ab11baf47ce5186fcb7067ae74efdbd20896d5a4e0b84c15edafd31dce
DIST kopeninghours-23.04.0.tar.xz 71432 BLAKE2B bbdbb315613d0e7564bf6c9a97747625e4379c88bad69ad34e558138864f1cd8fd318230b0f97fa4cad9c01d3a3db92d45f136073f433f2031dc3777c94a3c39 SHA512 572d755e79da4f1568d6f26f038781981d4bb845f07cb944014fe9d0e39aed013e380825eb88170d23487d3d07edb69945fe4ab0933a13cf1e4b9c3a711367b0
+DIST kopeninghours-23.04.1.tar.xz 71740 BLAKE2B 828c40d09464673d3098cc01d582300a78baaf0fd223320e8c9609514278a2a1358d07e7dc7bb742826cf06a8e7d27ec1964a9d5cee363cc9b67d1dbb6eeaf14 SHA512 02cd56c313510a6fd44b7d3feeca9ef2a56004bc30cab555c5c388afb0176de52176e4bccdb718388ee05773132dd05e30b54cf770f7c4a7df4318782eddee67
diff --git a/dev-libs/kopeninghours/kopeninghours-23.04.1.ebuild b/dev-libs/kopeninghours/kopeninghours-23.04.1.ebuild
new file mode 100644
index 000000000000..bafa38060372
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-23.04.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.104.0
+QTMIN=5.15.5
+PYTHON_COMPAT=( python3_{9..11} )
+inherit ecm gear.kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}