summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-12 06:31:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-12 06:33:51 +0200
commit96b96c6951276a1089b8996cf21b785df87e1c8e (patch)
tree6e62c4a53463329543f0cd8aa3a39ec410e55d6c /dev-libs/jsoncpp
parentdev-python/regex: Bump to 2024.9.11 (diff)
downloadgentoo-96b96c6951276a1089b8996cf21b785df87e1c8e.tar.gz
gentoo-96b96c6951276a1089b8996cf21b785df87e1c8e.tar.bz2
gentoo-96b96c6951276a1089b8996cf21b785df87e1c8e.zip
dev-libs/jsoncpp: Bump to 1.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/jsoncpp')
-rw-r--r--dev-libs/jsoncpp/Manifest1
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.9.6.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/jsoncpp/Manifest b/dev-libs/jsoncpp/Manifest
index 32bbef99f8fd..44699d7bdf27 100644
--- a/dev-libs/jsoncpp/Manifest
+++ b/dev-libs/jsoncpp/Manifest
@@ -1 +1,2 @@
DIST jsoncpp-1.9.5.tar.gz 216055 BLAKE2B 744275297647be8f1ac7bbf6c818e5106fc122591b3fb68c37cf33f5b3b7d6666e8429bb7ca2ae693202a5a83c274303804e21ebb27f05ba235568bf75a9b375 SHA512 1d06e044759b1e1a4cc4960189dd7e001a0a4389d7239a6d59295af995a553518e4e0337b4b4b817e70da5d9731a4c98655af90791b6287870b5ff8d73ad8873
+DIST jsoncpp-1.9.6.tar.gz 212682 BLAKE2B efa5dea68ddc175391200077666204f7ec66cd1f96a889a2a3c53d0e22e1f96ead1a2e7a871940f60dbd4261650f133b83de428b9c8b663fa13bd7ab4b9fdffe SHA512 006d81f9f723dcfe875ebc2147449c07c5246bf97dd7b9eee1909decc914b051d6f3f06feb5c3dfa143d28773fb310aabb04a81dc447cc61513309df8eba8b08
diff --git a/dev-libs/jsoncpp/jsoncpp-1.9.6.ebuild b/dev-libs/jsoncpp/jsoncpp-1.9.6.ebuild
new file mode 100644
index 000000000000..0063c6350e4b
--- /dev/null
+++ b/dev-libs/jsoncpp/jsoncpp-1.9.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit meson-multilib python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp/"
+SRC_URI="
+ https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/26"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( app-text/doxygen )
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ # Follow Debian, Ubuntu, Arch convention for headers location
+ # bug #452234
+ --includedir include/jsoncpp
+ -Dtests=$(usex test true false)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson-multilib_src_compile
+
+ if use doc; then
+ echo "${PV}" > version || die
+ "${EPYTHON}" doxybuild.py --doxygen="${EPREFIX}"/usr/bin/doxygen || die
+ HTML_DOCS=( dist/doxygen/jsoncpp*/. )
+ fi
+}
+
+multilib_src_test() {
+ # increase test timeout due to failures on slower hardware
+ meson_src_test -t 2
+}