summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-11-28 10:00:50 +0000
committerMarek Szuba <marecki@gentoo.org>2019-11-28 10:08:02 +0000
commit5fd53520d2d29647ec433c9c357c01b7737976c2 (patch)
tree57ffbaf083f3166dc77748ebdb47c31081e2c1c3 /dev-libs/intel-neo
parentdev-util/intel-graphics-compiler: bump to 1.0.2878 (diff)
downloadgentoo-5fd53520d2d29647ec433c9c357c01b7737976c2.tar.gz
gentoo-5fd53520d2d29647ec433c9c357c01b7737976c2.tar.bz2
gentoo-5fd53520d2d29647ec433c9c357c01b7737976c2.zip
dev-libs/intel-neo: bump to 19.46.14807
Important changes since 19.38.14237: * added early support for Tiger Lake devices (OpenCL 2.1) * enabled thread-group preemption on same * enabled 64-bit atomics on Ice Lake and Tiger Lake * added support for Ice Lake device id 0x8A58 * use newer GMM API * added the clGetExecutionInfoIntel API Please note that as of this release Ice Lake platforms have been downgraded to Beta quality due to regression in certification tests. Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/intel-neo')
-rw-r--r--dev-libs/intel-neo/Manifest1
-rw-r--r--dev-libs/intel-neo/intel-neo-19.46.14807.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/intel-neo/Manifest b/dev-libs/intel-neo/Manifest
index 49d3fa0e2838..9e670cc9cc5c 100644
--- a/dev-libs/intel-neo/Manifest
+++ b/dev-libs/intel-neo/Manifest
@@ -1,3 +1,4 @@
DIST intel-neo-19.22.13062.tar.gz 2402939 BLAKE2B e47f19fa602444cb260a2cdd9b676201ec8e4c50fe55c4216f779b8edab3497b5249071edcf5d162457be4f72cd33868cf7a971d99b1ae60e7a5e3714a795e82 SHA512 81ad69d051add3eb8d64373ad2ede0b323a4330c9f18010130e9b3db4d78d6e30e2e37f01c0cb7a77e378af62d9d6dd62755a21b153ae753417a6a2556d61b66
DIST intel-neo-19.30.13641.tar.gz 2446018 BLAKE2B 640b3076c928eab80911d219dabda85029f544d62ff7d39de465f89844f244e75afe053f8475db79aba88a969252d3d5141f0167c8bc7f05120a71fd9ccfda26 SHA512 70aaccc74d74c1ecc9098e579fd6ad154b22eb6024f84aab626d92ece33f5d5d75bdded1656fa7250f34b5b69f69767f39e22b9777601152a5ae6b32d8e1c796
DIST intel-neo-19.38.14237.tar.gz 2480609 BLAKE2B d44b00038009d6fc549f7cb17f248f83b6848d152cbb0a0815a5537b4e6131e5087ec231d777eb425b13aee27954c4526ede4859305e5312ad34cc7ec32b0897 SHA512 5886c1565405410da27fd3f2f38e78e9d7017968ec92a2819206e53eeeace3903c3d14fae9b5a5abf582cece5fe1d54bc1db18301846c668af768fcac5854c91
+DIST intel-neo-19.46.14807.tar.gz 2582591 BLAKE2B 07f65bf191e81a863e840a85c89d7632edfde814da0a00beaac0124293bf44a4d7bc45abdb0d8444dafcdaba24f83194d37df55297e0d0b32c91f622498e75c4 SHA512 fdf37bd51ffbf286d00ec395ba7f6bd53e0555610ed88ef201f2baaf1a03fb73137d0cd502119aba4cb6e146d2cd03c08bd20e004e6be3381104af9e24381820
diff --git a/dev-libs/intel-neo/intel-neo-19.46.14807.ebuild b/dev-libs/intel-neo/intel-neo-19.46.14807.ebuild
new file mode 100644
index 000000000000..0209ef1590c5
--- /dev/null
+++ b/dev-libs/intel-neo/intel-neo-19.46.14807.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+MY_PN="compute-runtime"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for OpenCL, for Gen8 (Broadwell) and beyond"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="vaapi"
+
+BDEPEND="virtual/pkgconfig"
+COMMON="dev-libs/ocl-icd
+ >=dev-util/intel-graphics-compiler-1.0.2878
+ >=media-libs/gmmlib-19.3.4
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ >=x11-libs/libva-2.0.0
+ )"
+DEPEND="${COMMON}
+ media-libs/mesa" # for Khronos OpenGL headers
+RDEPEND="${COMMON}"
+
+DOCS=(
+ README.md
+ documentation/FAQ.md
+ documentation/LIMITATIONS.md
+)
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DKHRONOS_GL_HEADERS_DIR="${EPREFIX}/usr/include"
+ -DDISABLE_LIBVA=$(usex vaapi "OFF" "ON")
+ # If enabled, tests are automatically run during the compile phase
+ # - and we cannot run them because they require permissions to access
+ # the hardware.
+ -DSKIP_UNIT_TESTS=ON
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ "${ROOT}"/usr/bin/eselect opencl set --use-old ocl-icd
+}