summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2016-01-09 04:23:52 +0100
committerMaciej Mrozowski <reavertm@gentoo.org>2016-01-09 04:28:12 +0100
commitc5f15263cb5934dde6af72544a7aaeb0a22bdb3b (patch)
treec77bb1939024691450d82e63c3de4e9db8359c29 /dev-libs/injeqt
parentsys-fs/lxcfs: bump to 0.16 (diff)
downloadgentoo-c5f15263cb5934dde6af72544a7aaeb0a22bdb3b.tar.gz
gentoo-c5f15263cb5934dde6af72544a7aaeb0a22bdb3b.tar.bz2
gentoo-c5f15263cb5934dde6af72544a7aaeb0a22bdb3b.zip
dev-libs/injeqt: Preserve CXX flags, fixes bug 570954.
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/injeqt')
-rw-r--r--dev-libs/injeqt/files/injeqt-cmake-preserve-cxxflags.patch12
-rw-r--r--dev-libs/injeqt/injeqt-1.0.0-r1.ebuild35
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/injeqt/files/injeqt-cmake-preserve-cxxflags.patch b/dev-libs/injeqt/files/injeqt-cmake-preserve-cxxflags.patch
new file mode 100644
index 000000000000..7428c5c673fc
--- /dev/null
+++ b/dev-libs/injeqt/files/injeqt-cmake-preserve-cxxflags.patch
@@ -0,0 +1,12 @@
+diff -ruN injeqt-1.0.0/CMakeLists.txt injeqt-my/CMakeLists.txt
+--- injeqt-1.0.0/CMakeLists.txt 2015-01-25 00:09:26.000000000 +0100
++++ injeqt-my/CMakeLists.txt 2016-01-09 04:01:39.162295444 +0100
+@@ -39,7 +39,7 @@
+
+ set (WARNINGS "-Werror -W -Wall -Wextra -Wundef -Wunused -Wuninitialized -Wcast-align -Wpointer-arith -Woverloaded-virtual -Wnon-virtual-dtor -fno-common")
+ set (VISIBILITY "-fvisibility=hidden -fvisibility-inlines-hidden")
+-set (CMAKE_CXX_FLAGS "-std=c++11 ${WARNINGS} ${VISIBILITY}")
++set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 ${WARNINGS} ${VISIBILITY}")
+
+ if (CMAKE_BUILD_TYPE STREQUAL "Debug")
+ set (CMAKE_CXX_FLAGS "-O0 ${CMAKE_CXX_FLAGS}")
diff --git a/dev-libs/injeqt/injeqt-1.0.0-r1.ebuild b/dev-libs/injeqt/injeqt-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..444b78c7796e
--- /dev/null
+++ b/dev-libs/injeqt/injeqt-1.0.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Dependency injection framework for Qt5"
+HOMEPAGE="https://github.com/vogel/injeqt"
+SRC_URI="https://github.com/vogel/injeqt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.4.2:5
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qttest-5.4.2:5 )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-cmake-preserve-cxxflags.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_EXAMPLES=ON
+ $(cmake-utils_use_disable test TESTS)
+ )
+ cmake-utils_src_configure
+}