summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-11 01:07:23 +0100
committerSam James <sam@gentoo.org>2024-09-11 01:07:23 +0100
commit8169ebbc4e6894a4f5ca3bf9d666baa04014ce33 (patch)
tree5d7b1dde75366725067fb3d599e7b2f05fe0aa66 /dev-libs/glib
parentapp-emulation/qemu: fix systemtap has_version check (diff)
downloadgentoo-8169ebbc4e6894a4f5ca3bf9d666baa04014ce33.tar.gz
gentoo-8169ebbc4e6894a4f5ca3bf9d666baa04014ce33.tar.bz2
gentoo-8169ebbc4e6894a4f5ca3bf9d666baa04014ce33.zip
dev-libs/glib: fix systemtap has_version check
Bug: https://bugs.gentoo.org/938302 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/glib-2.76.4.ebuild2
-rw-r--r--dev-libs/glib/glib-2.78.3.ebuild2
-rw-r--r--dev-libs/glib/glib-2.78.4-r1.ebuild2
-rw-r--r--dev-libs/glib/glib-2.78.6.ebuild2
-rw-r--r--dev-libs/glib/glib-2.80.4.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/glib/glib-2.76.4.ebuild b/dev-libs/glib/glib-2.76.4.ebuild
index 52b264f3f701..9f9236bbcf7e 100644
--- a/dev-libs/glib/glib-2.76.4.ebuild
+++ b/dev-libs/glib/glib-2.76.4.ebuild
@@ -199,7 +199,7 @@ multilib_src_configure() {
)
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
local native_file="${T}"/meson.${CHOST}.ini.local
cat >> ${native_file} <<-EOF || die
[binaries]
diff --git a/dev-libs/glib/glib-2.78.3.ebuild b/dev-libs/glib/glib-2.78.3.ebuild
index 52b264f3f701..9f9236bbcf7e 100644
--- a/dev-libs/glib/glib-2.78.3.ebuild
+++ b/dev-libs/glib/glib-2.78.3.ebuild
@@ -199,7 +199,7 @@ multilib_src_configure() {
)
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
local native_file="${T}"/meson.${CHOST}.ini.local
cat >> ${native_file} <<-EOF || die
[binaries]
diff --git a/dev-libs/glib/glib-2.78.4-r1.ebuild b/dev-libs/glib/glib-2.78.4-r1.ebuild
index 6ae0c3800fd5..6155dc22b039 100644
--- a/dev-libs/glib/glib-2.78.4-r1.ebuild
+++ b/dev-libs/glib/glib-2.78.4-r1.ebuild
@@ -208,7 +208,7 @@ multilib_src_configure() {
)
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
local native_file="${T}"/meson.${CHOST}.ini.local
cat >> ${native_file} <<-EOF || die
[binaries]
diff --git a/dev-libs/glib/glib-2.78.6.ebuild b/dev-libs/glib/glib-2.78.6.ebuild
index 004b9796f159..084d5059aa14 100644
--- a/dev-libs/glib/glib-2.78.6.ebuild
+++ b/dev-libs/glib/glib-2.78.6.ebuild
@@ -207,7 +207,7 @@ multilib_src_configure() {
)
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
local native_file="${T}"/meson.${CHOST}.ini.local
cat >> ${native_file} <<-EOF || die
[binaries]
diff --git a/dev-libs/glib/glib-2.80.4.ebuild b/dev-libs/glib/glib-2.80.4.ebuild
index 79fbaf94dbc0..e67299e0d365 100644
--- a/dev-libs/glib/glib-2.80.4.ebuild
+++ b/dev-libs/glib/glib-2.80.4.ebuild
@@ -208,7 +208,7 @@ multilib_src_configure() {
)
# Workaround for bug #938302
- if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ if use systemtap && has_version "dev-debug/systemtap[-dtrace-symlink(+)]" ; then
local native_file="${T}"/meson.${CHOST}.ini.local
cat >> ${native_file} <<-EOF || die
[binaries]