summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/btparser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/btparser')
-rw-r--r--dev-libs/btparser/Manifest2
-rw-r--r--dev-libs/btparser/btparser-0.24.ebuild40
-rw-r--r--dev-libs/btparser/btparser-0.25.ebuild44
-rw-r--r--dev-libs/btparser/metadata.xml5
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/btparser/Manifest b/dev-libs/btparser/Manifest
new file mode 100644
index 000000000000..5f07106efaf6
--- /dev/null
+++ b/dev-libs/btparser/Manifest
@@ -0,0 +1,2 @@
+DIST btparser-0.24.tar.xz 353700 SHA256 9cc1e172c864afb6dec45850ed7b2fa605d39013918027df81800899ea654e32 SHA512 3aee4a8cbc8cda7017cc7203b670ba30443b5f302d728ecb7ce06a9569367543669c9c02d10a71b2bbf0bbc65cb927c0e25a53a422fc3be5e4a2ee51e5495198 WHIRLPOOL a5feb168f9ab2d4442c37ba388c0ed4708781ab2e6becc89ea20ac2601a698600e47721c0818aad8e4df93888cfadfdec68aace0f659985d95cecb31cdb01b8f
+DIST btparser-0.25.tar.xz 355736 SHA256 afaad61a52d90c7dcc65f53485ced298e9cd9dab6a9ff611c4eb40bfcc2a786e SHA512 fc3f1f440fdf19eba8d698bdde9b1f197cbf663b7f8a53dea98c9fa6ffe4cd23a12b8d46d211fcff30dd4adbd3998723f7a2afb19c6c5d73da34156bc7877b56 WHIRLPOOL 5ed0fa3b7c97243d120c11d5870c4a682033501151df22bbf9a7b12832cecc888b3fad3ab6e0269c43835108af8bbd1b4ad3c81bb983b9bcd2ff55f2919257e1
diff --git a/dev-libs/btparser/btparser-0.24.ebuild b/dev-libs/btparser/btparser-0.24.ebuild
new file mode 100644
index 000000000000..2a1092cfdaaf
--- /dev/null
+++ b/dev-libs/btparser/btparser-0.24.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="Parser and analyzer for backtraces produced by gdb"
+HOMEPAGE="https://fedorahosted.org/btparser/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.21:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+src_configure() {
+ # Configure checks for python.pc; our python-2.7 installs python-2.7.pc,
+ # while python-2.6 does not install any pkgconfig file.
+ export PYTHON_CFLAGS=$(python-config --includes)
+ export PYTHON_LIBS=$(python-config --libs)
+
+ econf \
+ $(use_enable static-libs static) \
+ --disable-maintainer-mode
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
diff --git a/dev-libs/btparser/btparser-0.25.ebuild b/dev-libs/btparser/btparser-0.25.ebuild
new file mode 100644
index 000000000000..dfa186664371
--- /dev/null
+++ b/dev-libs/btparser/btparser-0.25.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools gnome2 python-single-r1
+
+DESCRIPTION="Parser and analyzer for backtraces produced by gdb"
+HOMEPAGE="https://fedorahosted.org/btparser/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="amd64 x86"
+
+IUSE="static-libs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.21:2
+"
+DEPEND="${RDEPEND}"
+
+# Incomplete tarball for tests
+RESTRICT="test"
+
+src_prepare() {
+ eautoreconf # to prevent maintainer mode
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Configure checks for python.pc; our python-2.7 installs python-2.7.pc,
+ # while python-2.6 does not install any pkgconfig file.
+ export PYTHON_CFLAGS=$(python-config --includes)
+ export PYTHON_LIBS=$(python-config --libs)
+
+ gnome2_src_configure \
+ $(use_enable static-libs static)
+}
diff --git a/dev-libs/btparser/metadata.xml b/dev-libs/btparser/metadata.xml
new file mode 100644
index 000000000000..6e0e2ecb48ca
--- /dev/null
+++ b/dev-libs/btparser/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>