summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-30 10:59:33 +0100
committerSam James <sam@gentoo.org>2023-03-30 10:59:59 +0100
commiteb6872bdbbe06618c0a8d412900c390a59e893f1 (patch)
tree082ffe94e5cbb2fdb3555e31af09a310a31239db /dev-libs/Ice
parentmedia-gfx/gmic: Stabilize 3.2.0 x86, #903567 (diff)
downloadgentoo-eb6872bdbbe06618c0a8d412900c390a59e893f1.tar.gz
gentoo-eb6872bdbbe06618c0a8d412900c390a59e893f1.tar.bz2
gentoo-eb6872bdbbe06618c0a8d412900c390a59e893f1.zip
dev-libs/Ice: drop 3.6.5-r2, 3.7.8
Bug: https://bugs.gentoo.org/903570 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/Ice')
-rw-r--r--dev-libs/Ice/Ice-3.6.5-r2.ebuild336
-rw-r--r--dev-libs/Ice/Ice-3.7.8.ebuild258
-rw-r--r--dev-libs/Ice/Manifest2
-rw-r--r--dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch50
-rw-r--r--dev-libs/Ice/files/Ice-3.6.5-csharp.patch50
-rw-r--r--dev-libs/Ice/files/Ice-3.6.5-db6.patch48
6 files changed, 0 insertions, 744 deletions
diff --git a/dev-libs/Ice/Ice-3.6.5-r2.ebuild b/dev-libs/Ice/Ice-3.6.5-r2.ebuild
deleted file mode 100644
index d7ea1ea0d531..000000000000
--- a/dev-libs/Ice/Ice-3.6.5-r2.ebuild
+++ /dev/null
@@ -1,336 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-RUBY_OPTIONAL="yes"
-USE_RUBY="ruby27"
-
-PHP_EXT_NAME="IcePHP"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-PHP_EXT_OPTIONAL_USE=php
-
-USE_PHP="php7-4"
-
-# This variable does not belong to any eclass. It is solely used in this ebuild
-BERKDB_SLOTS=( 6.2 6.1 5.3 5.1 4.8 )
-
-inherit db-use mono-env php-ext-source-r3 python-r1 ruby-ng toolchain-funcs
-
-DESCRIPTION="ICE middleware C++ library and generator tools"
-HOMEPAGE="https://zeroc.com/products/ice"
-SRC_URI="https://github.com/zeroc-ice/ice/archive/v${PV}.tar.gz -> ${P}.tar.gz
- doc? ( https://download.zeroc.com/Ice/$(ver_cut 1-2)/${PN}-3.6.4.pdf )"
-LICENSE="GPL-2"
-SLOT="0/36"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="debug doc examples +readline mono php python ruby test"
-RESTRICT="test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=dev-libs/expat-2.0.1
- >=app-arch/bzip2-1.0.5
- dev-libs/openssl:0=
- virtual/libcrypt:=
- || (
- $(for slot in ${BERKDB_SLOTS[@]} ; do printf '%s\n' "sys-libs/db:${slot}[cxx]" ; done)
- )
- dev-cpp/libmcpp
- python? ( ${PYTHON_DEPS} )
- ruby? ( $(ruby_implementation_depend ruby27) )
- mono? ( dev-lang/mono )"
-DEPEND="${RDEPEND}
- readline? ( sys-libs/readline:0= )
- test? (
- ${PYTHON_DEPS}
- dev-python/passlib[${PYTHON_USEDEP}]
- )"
-
-# Maintainer notes:
-# TODO: java bindings
-
-S="${WORKDIR}/${P,}"
-PHP_EXT_S="${S}/php"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.6.3-no-arch-opts.patch"
- "${FILESDIR}/${P}-db6.patch"
- "${FILESDIR}/${P}-csharp.patch"
-)
-
-pkg_setup() {
- # prevent ruby-ng.eclass from messing with pkg_setup
- return
-}
-
-src_unpack() {
- # prevent ruby-ng.eclass from messing with src_unpack
- default
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e 's|-L\$\(libdir\)||' \
- cpp/config/Make.rules || die
-
- sed -i \
- -e 's|-O2 ||g' \
- -e 's|-Werror ||g' \
- cpp/config/Make.rules.Linux || die
-
- sed -i \
- -e 's|install-common||' \
- {cpp,csharp,php,python,ruby}/Makefile || die
-
- sed -i \
- -e 's|-f -root|-f -gacdir $(GAC_DIR) -root|' \
- csharp/config/Make.rules.cs || die
-
- # skip mono tests, bug #498484
- sed -i \
- -e '/SUBDIRS/s|\ test||' \
- csharp/Makefile || die
-
- # skip udp test due to multicast
- # skip IceGrid/admin bug #649850
- # skip IceSSL tests due to requirement of internet connection
- # skip IceStorm/single bug #636834
- # IceUtil/stacktrace and IceStorm/stress fail with USE=debug
- # Glacier2/staticFiltering requires network access
- sed -i \
- -e 's|allTests.py|allTests.py --rfilter=udp --rfilter=IceGrid\/admin --rfilter=IceSSL --rfilter=IceStorm\/single --rfilter=IceStorm\/stress --rfilter=IceUtil\/stacktrace --rfilter=Glacier2\/staticFiltering|' \
- cpp/Makefile || die
-
- # fails even on unicode locale
- sed -i \
- -e 's|allTests.py|allTests.py --rfilter=Slice\/unicodePaths|' \
- ruby/Makefile || die
-
- # fix for x86 IceBox test
- sed -i \
- -e 's|"32"|""|' \
- scripts/TestUtil.py || die
-}
-
-src_configure() {
- suitable_db_version() {
- local ver
- for ver in "${BERKDB_SLOTS[@]}"; do
- if [[ -n $(db_findver sys-libs/db:${ver}) ]]; then
- echo "${ver}"
- return 0
- fi
- done
- die "No suitable BerkDB versions found, aborting"
- }
-
- MAKE_RULES=(
- "prefix=\"${ED}/usr\""
- "install_docdir=\"${ED}/usr/share/doc/${PF}\""
- "install_configdir=\"${ED}/usr/share/${P}/config\""
- "install_mandir=\"${ED}/usr/share/man/man1\""
- "embedded_runpath_prefix=\"${EPREFIX}/usr\""
- "LP64=yes"
- "new_dtags=yes"
- "NOTEST=$(usex !test)"
- "USE_READLINE=$(usex readline)"
- "OPTIMIZE=$(usex !debug)"
- )
-
- local BERKDB_VERSION="$(suitable_db_version)"
- MAKE_RULES+=("DB_FLAGS=-I$(db_includedir ${BERKDB_VERSION})")
- sed -i \
- -e "s|g++|$(tc-getCXX)|" \
- -e "s|\(CFLAGS[[:space:]]*=\)|\1 ${CFLAGS}|" \
- -e "s|\(CXXFLAGS[[:space:]]*=\)|\1 ${CXXFLAGS}|" \
- -e "s|\(LDFLAGS[[:space:]]*=\)|\1 ${LDFLAGS}|" \
- -e "s|\(DB_LIBS[[:space:]]*=\) \-ldb_cxx|\1 -ldb_cxx-$(db_findver sys-libs/db:${BERKDB_VERSION})|" \
- cpp/config/Make.rules{,.Linux} python/config/Make.rules || die
-
- if use python; then
- local S="${S}/python"
- python_copy_sources
- fi
-
- if use ruby; then
- SITERUBY="$(ruby26 -r rbconfig -e 'print RbConfig::CONFIG["sitelibdir"]')"
- SITERUBYARCH="$(ruby26 -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')"
- MAKE_RULES_RUBY=(
- "install_rubydir=\"${ED}/${SITERUBY}\""
- "install_libdir=\"${ED}/${SITERUBYARCH}\""
- )
-
- # make it use ruby26 only
- sed -i \
- -e 's|RUBY = ruby|\026|' \
- ruby/config/Make.rules || die
- sed -i \
- -e 's|env ruby|\026|' \
- ruby/config/s2rb.rb || die
- sed -i \
- -e 's|env ruby|\026|' \
- ruby/scripts/slice2rb || die
- sed -i \
- -e 's|output.write("ruby|\026|' \
- scripts/TestUtil.py || die
- fi
-
- MAKE_RULES_MONO=(
- "GACINSTALL=yes"
- "GAC_ROOT=\"${ED}/usr/$(get_libdir)\""
- "GAC_DIR=\"${EPREFIX}/usr/$(get_libdir)\""
- "install_libdir=\"${ED}/usr/$(get_libdir)\""
- "install_pkgconfigdir=\"${ED}/usr/$(get_libdir)/pkgconfig\""
- )
-
- if has_version ">dev-lang/mono-4"; then
- MAKE_RULES_MONO+=("MCS=mcs")
- fi
-
- use test && python_setup
-}
-
-src_compile() {
- # Do not remove this export or build will break!
- tc-export CXX
-
- emake -C cpp "${MAKE_RULES[@]}"
-
- if use php; then
- local i
- for i in $(php_get_slots); do
- mkdir -p "${WORKDIR}/${i}" || die
- cp -r "${PHP_EXT_S}" "${WORKDIR}/${i}/" || die "Failed to copy source ${PHP_EXT_S} to PHP target directory"
-
- pushd "${WORKDIR}/${i}" >/dev/null || die
- ln -s "${S}/cpp" || die
- ln -s "${S}/config" || die
- ln -s "${S}/slice" || die
- ln -s "${S}/Makefile" || die
-
- emake -C php "${MAKE_RULES[@]}" USE_NAMESPACES=yes "PHP_CONFIG=\"${EPREFIX}/usr/$(get_libdir)/${i}/bin/php-config\""
- popd >/dev/null || die
- done
- fi
-
- if use python; then
- building() {
- emake -C "${BUILD_DIR}" "${MAKE_RULES[@]}" PYTHON="${EPYTHON}"
- }
- local S="${S}/python"
- python_foreach_impl building
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}"
- fi
-
- if use mono; then
- emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}"
- fi
-}
-
-src_test() {
- local -x LD_LIBRARY_PATH="${S}/cpp/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
- emake -C cpp "${MAKE_RULES[@]}" test
-
- # php tests require the extension loaded and are therefore skipped
-
- if use python; then
- testing() {
- PYTHONPATH="${BUILD_DIR}"/python emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- PYTHON="${EPYTHON}" \
- install_pythondir="\"${D}/$(python_get_sitedir)\"" \
- install_libdir="\"${D}/$(python_get_sitedir)\"" test
- }
- local S="${S}/python"
- python_foreach_impl testing
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" test
- fi
-
- if use mono; then
- # skip mono tests, bug #498484
- ewarn "Tests for C# are currently disabled."
- #emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}" test
- fi
-}
-
-src_install() {
- local DOCS=( CHANGELOG*.md README.md )
- use doc && DOCS+=( "${DISTDIR}/${PN}-3.6.4.pdf" )
- einstalldocs
-
- insinto /usr/share/${P}
- doins -r slice
-
- emake -C cpp "${MAKE_RULES[@]}" install
-
- if use examples; then
- docinto examples-cpp
- dodoc cpp/config/*.cfg
- docompress -x /usr/share/doc/${PF}/examples-cpp
- fi
-
- if use php; then
- insinto "/usr/share/php/${PN}"
-
- local i
- while IFS="" read -d $'\0' -r i; do
- doins "${i}"
- done < <(find "${S}/php/lib/" -name '*.php' -print0)
-
- pushd "${ED}/usr/share/${P}/slice" >/dev/null || die
-
- local -x LD_LIBRARY_PATH="${ED}/usr/$(get_libdir):${LD_LIBRARY_PATH}"
- for i in *; do
- mkdir -p "${ED}/usr/share/php/${i}" || die
- "${ED}"/usr/bin/slice2php \
- -I"${ED}/usr/share/${P}/slice/" --all \
- --output-dir "${ED}/usr/share/php/${i}" \
- --ice "${ED}/usr/share/${P}/slice/${i}"/*
- done
-
- for i in $(php_get_slots); do
- php_init_slot_env "${i}"
- insinto "${EXT_DIR}"
- newins "php/lib/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so"
- done
- php-ext-source-r3_createinifiles
-
- popd >/dev/null || die
- fi
-
- if use python; then
- installation() {
- mkdir -p "${D}/$(python_get_sitedir)" || die
-
- emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- install_pythondir="\"${D}/$(python_get_sitedir)\"" \
- install_libdir="\"${D}/$(python_get_sitedir)\"" \
- install
- python_optimize
- }
- local S="${S}/python"
- python_foreach_impl installation
- fi
-
- if use ruby; then
- dodir "${SITERUBY}"
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" install
- fi
-
- if use mono; then
- emake -C csharp "${MAKE_RULES[@]}" "${MAKE_RULES_MONO[@]}" install
- fi
-}
diff --git a/dev-libs/Ice/Ice-3.7.8.ebuild b/dev-libs/Ice/Ice-3.7.8.ebuild
deleted file mode 100644
index a512d98ba711..000000000000
--- a/dev-libs/Ice/Ice-3.7.8.ebuild
+++ /dev/null
@@ -1,258 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-RUBY_OPTIONAL="yes"
-USE_RUBY="ruby27"
-
-PHP_EXT_NAME="IcePHP"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-PHP_EXT_OPTIONAL_USE=php
-
-USE_PHP="php8-0 php8-1 php8-2"
-
-inherit php-ext-source-r3 python-r1 ruby-ng toolchain-funcs
-
-DESCRIPTION="ICE middleware C++ library and generator tools"
-HOMEPAGE="https://zeroc.com/products/ice"
-SRC_URI="https://github.com/zeroc-ice/ice/archive/v${PV}.tar.gz -> ${P}.tar.gz
- doc? ( https://download.zeroc.com/Ice/$(ver_cut 1-2)/${PN}-3.7.1.pdf )"
-LICENSE="GPL-2"
-SLOT="0/37"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="debug doc examples php python ruby test"
-RESTRICT="test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=app-arch/bzip2-1.0.5
- >=dev-libs/expat-2.0.1
- dev-libs/libedit
- dev-cpp/libmcpp
- dev-db/lmdb:=
- dev-libs/openssl:0=
- virtual/libcrypt:=
- python? ( ${PYTHON_DEPS} )
- ruby? ( $(ruby_implementation_depend ruby27) )"
-DEPEND="${RDEPEND}
- test? (
- ${PYTHON_DEPS}
- dev-python/passlib[${PYTHON_USEDEP}]
- )"
-
-# Maintainer notes:
-# TODO: java bindings
-
-S="${WORKDIR}/${P,}"
-PHP_EXT_S="${S}/php"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-musl-build.patch"
- "${FILESDIR}/${P}-py3k11.patch"
-)
-
-pkg_setup() {
- # prevent ruby-ng.eclass from messing with pkg_setup
- return
-}
-
-src_unpack() {
- # prevent ruby-ng.eclass from messing with src_unpack
- default
-}
-
-src_prepare() {
- default
-
- sed -i \
- -e 's|-Werror ||g' \
- config/Make.rules.Linux || die
-
- # fix for x86 IceBox test
- sed -i \
- -e 's|"32"|""|' \
- scripts/IceBoxUtil.py || die
-
- if use !test; then
- # Disable building tests
- sed -i \
- -e 's|include \$(top_srcdir)/config/Make.tests.rules||' \
- config/Make.rules || die
- fi
-}
-
-src_configure() {
- MAKE_RULES=(
- "embedded_runpath_prefix=\"${EPREFIX}/usr\""
- "OPTIMIZE=$(usex !debug)"
- "V=1"
- )
-
- if use python; then
- local S="${S}/python"
- python_copy_sources
- fi
-
- if use ruby; then
- SITERUBY="$(ruby27 -r rbconfig -e 'print RbConfig::CONFIG["sitelibdir"]')"
- SITERUBYARCH="$(ruby27 -r rbconfig -e 'print RbConfig::CONFIG["sitearchdir"]')"
- MAKE_RULES_RUBY=(
- "install_rubydir=\"${EPREFIX}/${SITERUBY}\""
- "install_rubylibdir=\"${EPREFIX}/${SITERUBYARCH}\""
- )
-
- # make it use ruby27 only
- sed -i \
- -e 's|RUBY ?= ruby|\027|' \
- ruby/config/Make.rules || die
- sed -i \
- -e 's|env ruby|\027|' \
- ruby/config/s2rb.rb || die
- sed -i \
- -e 's|env ruby|\027|' \
- ruby/scripts/slice2rb || die
- fi
-
- use test && python_setup
-}
-
-src_compile() {
- # Do not remove this export or build will break!
- tc-export CXX
-
- emake -C cpp "${MAKE_RULES[@]}"
-
- if use php; then
- local i
- for i in $(php_get_slots); do
- mkdir -p "${WORKDIR}/${i}" || die
- cp -r "${PHP_EXT_S}" "${WORKDIR}/${i}/" || die "Failed to copy source ${PHP_EXT_S} to PHP target directory"
-
- pushd "${WORKDIR}/${i}" >/dev/null || die
- ln -s "${S}/cpp" || die
- ln -s "${S}/config" || die
- ln -s "${S}/slice" || die
- ln -s "${S}/Makefile" || die
-
- emake -C php "${MAKE_RULES[@]}" "PHP_CONFIG=\"${EPREFIX}/usr/$(get_libdir)/${i}/bin/php-config\""
- popd >/dev/null || die
- done
- fi
-
- if use python; then
- building() {
- emake -C "${BUILD_DIR}" "${MAKE_RULES[@]}" PYTHON="${EPYTHON}"
- }
- local S="${S}/python"
- python_foreach_impl building
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}"
- fi
-}
-
-src_test() {
- local -x LD_LIBRARY_PATH="${S}/cpp/$(get_libdir)${LD_LIBRARY_PATH+:}${LD_LIBRARY_PATH}"
- emake -C cpp "${MAKE_RULES[@]}" test
-
- # php tests require the extension loaded and are therefore skipped
-
- if use python; then
- testing() {
- PYTHONPATH="${BUILD_DIR}"/python emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- PYTHON="${EPYTHON}" \
- install_pythondir="\"$(python_get_sitedir)\"" \
- install_libdir="\"$(python_get_sitedir)\"" test
- }
- local S="${S}/python"
- python_foreach_impl testing
- fi
-
- if use ruby; then
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_RUBY[@]}" test
- fi
-}
-
-src_install() {
- local DOCS=( CHANGELOG*.md README.md )
- use doc && DOCS+=( "${DISTDIR}/${PN}-3.7.1.pdf" )
- einstalldocs
-
- MAKE_RULES_INSTALL=(
- "prefix=\"${ED}/usr\""
- "install_docdir=\"${ED}/usr/share/doc/${PF}\""
- "install_configdir=\"${ED}/usr/share/${P}/config\""
- "install_mandir=\"${ED}/usr/share/man/man1\""
- )
-
- insinto /usr/share/${P}
- doins -r slice
-
- emake -C cpp "${MAKE_RULES[@]}" "${MAKE_RULES_INSTALL[@]}" install
-
- if use examples; then
- docinto examples-cpp
- dodoc cpp/config/*.cfg
- docompress -x /usr/share/doc/${PF}/examples-cpp
- fi
-
- if use php; then
- insinto "/usr/share/php/${PN}"
-
- local i
- while IFS="" read -d $'\0' -r i; do
- doins "${i}"
- done < <(find "${S}/php/lib/" -name '*.php' -print0)
-
- pushd "${ED}/usr/share/${P}/slice" >/dev/null || die
-
- local -x LD_LIBRARY_PATH="${ED}/usr/$(get_libdir):${LD_LIBRARY_PATH}"
- for i in *; do
- mkdir -p "${ED}/usr/share/php/${i}" || die
- "${ED}"/usr/bin/slice2php \
- -I"${ED}/usr/share/${P}/slice/" --all \
- --output-dir "${ED}/usr/share/php/${i}" \
- --ice "${ED}/usr/share/${P}/slice/${i}"/*
- done
-
- for i in $(php_get_slots); do
- php_init_slot_env "${i}"
- insinto "${EXT_DIR}"
- newins "php/lib/ice.so" "${PHP_EXT_NAME}.so"
- done
- php-ext-source-r3_createinifiles
-
- popd >/dev/null || die
- fi
-
- if use python; then
- installation() {
- mkdir -p "${D}/$(python_get_sitedir)" || die
-
- emake -C "${BUILD_DIR}" \
- "${MAKE_RULES[@]}" \
- "${MAKE_RULES_INSTALL[@]}" \
- install_pythondir="\"${D}/$(python_get_sitedir)\"" \
- install_libdir="\"${D}/$(python_get_sitedir)\"" \
- install
- python_optimize
- }
- local S="${S}/python"
- python_foreach_impl installation
- fi
-
- if use ruby; then
- MAKE_RULES_RUBY=(
- "install_rubydir=\"${ED}/${SITERUBY}\""
- "install_rubylibdir=\"${ED}/${SITERUBYARCH}\""
- )
- dodir "${SITERUBY}"
- emake -C ruby "${MAKE_RULES[@]}" "${MAKE_RULES_INSTALL[@]}" "${MAKE_RULES_RUBY[@]}" install
- fi
-}
diff --git a/dev-libs/Ice/Manifest b/dev-libs/Ice/Manifest
index a626ec223234..933d0fc9164c 100644
--- a/dev-libs/Ice/Manifest
+++ b/dev-libs/Ice/Manifest
@@ -1,4 +1,2 @@
-DIST Ice-3.6.4.pdf 8907736 BLAKE2B 5a631c1e2e147c8ed3b31a84192210c92bbe83e8644ec9d7d164d1b94a20069ce77f6baf54910ac00c7216cbc2979caac6fa78457e9292a84407e93000f9903a SHA512 9bd2d373eb83e08e563cab174a53063a490367dea3e4b910f93f0477c3817282c859f07e46e503006e9bd37678fb6da31a58b88bfabd217b5e371fff685321a0
-DIST Ice-3.6.5.tar.gz 5505499 BLAKE2B e16e8932f09270ac6bb86984ab47fa229ad873ee343ac4f56bb48b6f9547387ded0392a76302afac2c98b6d31da7c1faf294574cdba52654e7dea0af16b4169d SHA512 3431928e6168d716919aa9b3126d17a8ae14895bb78a369902a2bb350b2e82923f38ee17965ed3696512a016fcd34dc128e9aaca40fb2b032e7f7eb07bcb903b
DIST Ice-3.7.1.pdf 9351739 BLAKE2B 527f2c37aea19aedbfc580efd93ce4fae2eb7264342bb485822593e2da6fb75a61eea2b1a46187898af07f138d10bf9a213d0b2a0685c18cd1d4c624709a935b SHA512 199b59f14b87b2896ba970bf5aa32f6fd858cbd3fed18eac93acafe4e296db1361ca2d2000ed49f3390ed66c1d4ff8c1fcd3f14ab8197d7804c87fce422c8486
DIST Ice-3.7.8.tar.gz 11056950 BLAKE2B 66686d6e66a997badef53ee30782775047a2fa39d70fa8ed73c5e7a1bad3c3899efd8d68f557a416caacd65860a73834a6bdc3188730fa19a3f1e47f028c5e21 SHA512 eb5863cb5e83000199c27a5a505a19e5f1ec05e8575eb9cdc03f6db30447212e3b02e6adc70fb2ae6ddc63cfd93bc2b6b290f38919364ee9f08b238a0aa11e88
diff --git a/dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch b/dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch
deleted file mode 100644
index 149a31e1dd6c..000000000000
--- a/dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- ice-3.6.3/cpp/config/Make.rules.Linux~ 2015-06-27 16:56:56.000000000 +0200
-+++ ice-3.6.3/cpp/config/Make.rules.Linux 2015-06-27 17:23:45.810591931 +0200
-@@ -79,19 +79,6 @@
- CXXARCHFLAGS += -mtune=v8 -pipe -Wno-deprecated -DICE_USE_MUTEX_SHARED
- endif
-
-- #
-- # Only use multilib -m32/-m64 options for amd64 arch, x32 arch can also run
-- # in amd64 macines but doesn't use multilib, in this case MACHINE_TYPE will
-- # be x86_64 and HOST_ARCH x32.
-- #
-- ifeq ($(HOST_ARCH),amd64)
-- ifeq ($(LP64),yes)
-- CXXARCHFLAGS += -m64
-- else
-- CXXARCHFLAGS += -m32
-- endif
-- endif
--
- CXXFLAGS += $(CXXARCHFLAGS) -fvisibility=hidden -Wall -Werror -pthread
-
- # If MAXWARN is set then enable extra warnings
---- ice-3.6.3/config/Make.common.rules~ 2015-06-23 17:30:20.000000000 +0200
-+++ ice-3.6.3/config/Make.common.rules 2015-06-28 01:53:57.149666595 +0200
-@@ -101,25 +101,7 @@
- ifeq ($(LP64),)
- LP64 = yes
- endif
--
-- #
-- # x86 binaries build on x86_64 machine use 32 binsuffix
-- #
-- ifneq ($(STATICLIBS),yes)
-- ifneq ($(LP64),yes)
-- binsuffix = 32
-- endif
-- endif
- endif
--
-- #
-- # x86 builds uses 32 binsuffix
-- #
-- ifneq ($(STATICLIBS),yes)
-- ifeq ($(findstring $(MACHINE_TYPE),i386 i486 i586 i686),$(MACHINE_TYPE))
-- binsuffix = 32
-- endif
-- endif
- endif
-
- ifeq ($(CPP11),yes)
diff --git a/dev-libs/Ice/files/Ice-3.6.5-csharp.patch b/dev-libs/Ice/files/Ice-3.6.5-csharp.patch
deleted file mode 100644
index cfdc1f6a8d47..000000000000
--- a/dev-libs/Ice/files/Ice-3.6.5-csharp.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- ice-3.6.5/csharp/src/Makefile~ 2015-06-23 17:30:20.000000000 +0200
-+++ ice-3.6.5/csharp/src/Makefile 2015-06-27 20:07:04.217188211 +0200
-@@ -11,7 +11,7 @@
-
- include $(top_srcdir)/config/Make.rules.cs
-
--SUBDIRS = Ice IceStorm Glacier2 IcePatch2 IceGrid IceBox IceDiscovery IceLocatorDiscovery
-+SUBDIRS = Ice IceStorm Glacier2 IcePatch2 IceGrid IceBox IceSSL IceDiscovery IceLocatorDiscovery
-
- $(EVERYTHING)::
- @for subdir in $(SUBDIRS); \
---- /dev/null 2015-06-27 16:44:15.733558105 +0200
-+++ ice-3.6.5/csharp/lib/pkgconfig/IceSSL.pc 2015-06-27 20:19:30.731894653 +0200
-@@ -0,0 +1,10 @@
-+version = 3.6.5
-+mono_root = /usr
-+
-+name = IceSSL
-+
-+Name: ${name}
-+Description: IceSSL run-time support
-+Version: ${version}
-+Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
-+Requires: Ice = ${version}
---- /dev/null 2015-06-27 16:44:15.733558105 +0200
-+++ ice-3.6.5/csharp/lib/pkgconfig/IceDiscovery.pc 2015-06-27 20:20:44.312515987 +0200
-@@ -0,0 +1,10 @@
-+version = 3.6.5
-+mono_root = /usr
-+
-+name = IceDiscovery
-+
-+Name: ${name}
-+Description: IceDiscovery run-time support
-+Version: ${version}
-+Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
-+Requires: Ice = ${version}
---- /dev/null 2015-06-27 16:44:15.733558105 +0200
-+++ ice-3.6.5/csharp/lib/pkgconfig/IceLocatorDiscovery.pc 2015-06-27 20:21:22.206185123 +0200
-@@ -0,0 +1,10 @@
-+version = 3.6.5
-+mono_root = /usr
-+
-+name = IceLocatorDiscovery
-+
-+Name: ${name}
-+Description: IceLocatorDiscovery run-time support
-+Version: ${version}
-+Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
-+Requires: Ice = ${version}
diff --git a/dev-libs/Ice/files/Ice-3.6.5-db6.patch b/dev-libs/Ice/files/Ice-3.6.5-db6.patch
deleted file mode 100644
index b78fae76a453..000000000000
--- a/dev-libs/Ice/files/Ice-3.6.5-db6.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Avoid ambiguous ctor call (uint32_t vs DB_ENV*) with db 6.x.
-
---- ice-3.6.3/cpp/src/Freeze/SharedDbEnv.cpp.orig 2016-10-05 16:59:08.000000000 +0200
-+++ ice-3.6.3/cpp/src/Freeze/SharedDbEnv.cpp 2017-06-28 18:42:43.411869639 +0200
-@@ -530,7 +530,7 @@
- {
- if(_env == 0)
- {
-- _envHolder.reset(new DbEnv(0));
-+ _envHolder.reset(new DbEnv(0u));
- _env = _envHolder.get();
-
- if(_trace >= 1)
---- ice-3.6.3/cpp/src/FreezeScript/transformdb.cpp.orig 2016-10-05 16:59:08.000000000 +0200
-+++ ice-3.6.3/cpp/src/FreezeScript/transformdb.cpp 2017-06-28 19:15:03.928514164 +0200
-@@ -766,8 +766,8 @@
- //
- // Transform the database.
- //
-- DbEnv dbEnv(0);
-- DbEnv dbEnvNew(0);
-+ DbEnv dbEnv(0u);
-+ DbEnv dbEnvNew(0u);
- Freeze::TransactionPtr txNew;
- Freeze::ConnectionPtr connection;
- Freeze::ConnectionPtr connectionNew;
---- ice-3.6.3/cpp/src/FreezeScript/Util.cpp.orig 2016-10-05 16:59:08.000000000 +0200
-+++ ice-3.6.3/cpp/src/FreezeScript/Util.cpp 2017-06-28 19:22:29.318509063 +0200
-@@ -209,7 +209,7 @@
- {
- CatalogDataMap result;
-
-- DbEnv dbEnv(0);
-+ DbEnv dbEnv(0u);
- try
- {
- #ifdef _WIN32
---- ice-3.6.3/cpp/src/FreezeScript/DumpDB.cpp.orig 2016-10-05 16:59:08.000000000 +0200
-+++ ice-3.6.3/cpp/src/FreezeScript/DumpDB.cpp 2017-06-28 19:33:38.555168088 +0200
-@@ -481,7 +481,7 @@
- FreezeScript::ObjectFactoryPtr objectFactory = new FreezeScript::ObjectFactory;
- communicator->addObjectFactory(objectFactory, "");
-
-- DbEnv dbEnv(0);
-+ DbEnv dbEnv(0u);
- DbTxn* txn = 0;
- Freeze::ConnectionPtr connection;
- int status = EXIT_SUCCESS;