summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2020-01-23 11:27:30 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-01-23 11:27:57 -0600
commitc96064ddc43312a5efdd935ae2dab684e6ec9068 (patch)
tree3d04f755f5c5f546bda442be0fddff317516c5a4 /dev-lang
parentdev-lang/go: prefer go over go-bootstrap for building (diff)
downloadgentoo-c96064ddc43312a5efdd935ae2dab684e6ec9068.tar.gz
gentoo-c96064ddc43312a5efdd935ae2dab684e6ec9068.tar.bz2
gentoo-c96064ddc43312a5efdd935ae2dab684e6ec9068.zip
dev-lang/go: drop gccgo use flag
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/go-9999.ebuild18
1 files changed, 3 insertions, 15 deletions
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index e72c431625b7..405ca751d02f 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -37,12 +37,10 @@ HOMEPAGE="https://golang.org"
LICENSE="BSD"
SLOT="0/${PV}"
-IUSE="gccgo"
-BDEPEND="gccgo? ( >=sys-devel/gcc-5[go(-)] )
- !gccgo? ( || (
+BDEPEND="|| (
dev-lang/go
- dev-lang/go-bootstrap ) )"
+ dev-lang/go-bootstrap )"
RDEPEND="!<dev-go/go-tools-0_pre20150902"
# These test data objects have writable/executable stacks.
@@ -135,17 +133,7 @@ src_unpack()
src_compile()
{
- if use gccgo; then
- export GOROOT_BOOTSTRAP="${WORKDIR}/go-bootstrap"
- mkdir -p "${GOROOT_BOOTSTRAP}/bin" || die
- local go_binary=$(gcc-config --get-bin-path)/go-$(gcc-major-version)
- [[ -x ${go_binary} ]] || go_binary=$(
- find "${EPREFIX}"/usr/${CHOST}/gcc-bin/*/go-$(gcc-major-version) |
- sort -V | tail -n1)
- [[ -x ${go_binary} ]] ||
- die "go-$(gcc-major-version): command not found"
- ln -s "${go_binary}" "${GOROOT_BOOTSTRAP}/bin/go" || die
- elif has_version -b dev-lang/go; then
+ if has_version -b dev-lang/go; then
export GOROOT_BOOTSTRAP="${BROOT}/usr/lib/go"
elif has_version -b dev-lang/go-bootstrap; then
export GOROOT_BOOTSTRAP="${BROOT}/usr/lib/go-bootstrap"