summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-08 11:36:28 +0000
committerSam James <sam@gentoo.org>2024-01-08 12:01:22 +0000
commit447577139df782f0534903446afda10598a8d9e1 (patch)
treec565069adbe7f3ce8a5d11870cb9ec33b7c3243f /dev-lang
parentapp-i18n/mozc: dev-util/ninja -> app-alternatives/ninja (diff)
downloadgentoo-447577139df782f0534903446afda10598a8d9e1.tar.gz
gentoo-447577139df782f0534903446afda10598a8d9e1.tar.bz2
gentoo-447577139df782f0534903446afda10598a8d9e1.zip
dev-lang/rust: dev-util/ninja -> app-alternatives/ninja
All of these will be using app-alternatives/ninja anyway as they're not calling ninja-reference, so make the dep reflect reality. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/rust-1.65.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.66.1.ebuild4
-rw-r--r--dev-lang/rust/rust-1.67.1-r1.ebuild4
-rw-r--r--dev-lang/rust/rust-1.68.2.ebuild4
-rw-r--r--dev-lang/rust/rust-1.69.0-r1.ebuild4
-rw-r--r--dev-lang/rust/rust-1.70.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.71.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.71.1.ebuild4
-rw-r--r--dev-lang/rust/rust-1.72.0-r1.ebuild4
-rw-r--r--dev-lang/rust/rust-1.73.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.74.1.ebuild2
11 files changed, 21 insertions, 21 deletions
diff --git a/dev-lang/rust/rust-1.65.0.ebuild b/dev-lang/rust/rust-1.65.0.ebuild
index dba45f533557..1f262619cd79 100644
--- a/dev-lang/rust/rust-1.65.0.ebuild
+++ b/dev-lang/rust/rust-1.65.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -94,7 +94,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
diff --git a/dev-lang/rust/rust-1.66.1.ebuild b/dev-lang/rust/rust-1.66.1.ebuild
index 244c76155e97..a986d1c4b784 100644
--- a/dev-lang/rust/rust-1.66.1.ebuild
+++ b/dev-lang/rust/rust-1.66.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -94,7 +94,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
diff --git a/dev-lang/rust/rust-1.67.1-r1.ebuild b/dev-lang/rust/rust-1.67.1-r1.ebuild
index 35651f5b601d..dbd7af6c7240 100644
--- a/dev-lang/rust/rust-1.67.1-r1.ebuild
+++ b/dev-lang/rust/rust-1.67.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -94,7 +94,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
diff --git a/dev-lang/rust/rust-1.68.2.ebuild b/dev-lang/rust/rust-1.68.2.ebuild
index 056c98c54168..9645429fcf92 100644
--- a/dev-lang/rust/rust-1.68.2.ebuild
+++ b/dev-lang/rust/rust-1.68.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -94,7 +94,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
diff --git a/dev-lang/rust/rust-1.69.0-r1.ebuild b/dev-lang/rust/rust-1.69.0-r1.ebuild
index 58beb5133af2..ffa8d42d6822 100644
--- a/dev-lang/rust/rust-1.69.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.69.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -94,7 +94,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
diff --git a/dev-lang/rust/rust-1.70.0.ebuild b/dev-lang/rust/rust-1.70.0.ebuild
index be96c9f2ff41..d9b78ad1a4d6 100644
--- a/dev-lang/rust/rust-1.70.0.ebuild
+++ b/dev-lang/rust/rust-1.70.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -94,7 +94,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
diff --git a/dev-lang/rust/rust-1.71.0.ebuild b/dev-lang/rust/rust-1.71.0.ebuild
index 04611e1527e8..707d48f5834b 100644
--- a/dev-lang/rust/rust-1.71.0.ebuild
+++ b/dev-lang/rust/rust-1.71.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -94,7 +94,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
diff --git a/dev-lang/rust/rust-1.71.1.ebuild b/dev-lang/rust/rust-1.71.1.ebuild
index 10327d346ac0..77ac02a5b1b4 100644
--- a/dev-lang/rust/rust-1.71.1.ebuild
+++ b/dev-lang/rust/rust-1.71.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -94,7 +94,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
diff --git a/dev-lang/rust/rust-1.72.0-r1.ebuild b/dev-lang/rust/rust-1.72.0-r1.ebuild
index 1cb2e55b627c..c4277fbefd8c 100644
--- a/dev-lang/rust/rust-1.72.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.72.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -96,7 +96,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
diff --git a/dev-lang/rust/rust-1.73.0.ebuild b/dev-lang/rust/rust-1.73.0.ebuild
index 6143d4cd496e..efb165def423 100644
--- a/dev-lang/rust/rust-1.73.0.ebuild
+++ b/dev-lang/rust/rust-1.73.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -95,7 +95,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )
diff --git a/dev-lang/rust/rust-1.74.1.ebuild b/dev-lang/rust/rust-1.74.1.ebuild
index b77148aaa18b..ee549d7acd88 100644
--- a/dev-lang/rust/rust-1.74.1.ebuild
+++ b/dev-lang/rust/rust-1.74.1.ebuild
@@ -95,7 +95,7 @@ BDEPEND="${PYTHON_DEPS}
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
>=dev-util/cmake-3.13.4
- dev-util/ninja
+ app-alternatives/ninja
)
test? ( sys-devel/gdb )
verify-sig? ( sec-keys/openpgp-keys-rust )