summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-03-09 11:46:24 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-03-09 11:53:58 +0100
commit765823f832c01d4332d40e59d32b626cb40985a6 (patch)
tree489b7694dad9ef14432aadd67d9684d9a68a463d /dev-lang/zig
parentsys-fs/ncdu: adjust ebuild for slotted Zig (diff)
downloadgentoo-765823f832c01d4332d40e59d32b626cb40985a6.tar.gz
gentoo-765823f832c01d4332d40e59d32b626cb40985a6.tar.bz2
gentoo-765823f832c01d4332d40e59d32b626cb40985a6.zip
dev-lang/zig: downgrade ewarn to elog
ewarn and higher should, if possible, only be used conditionally and check-reqs_pkg_setup already issues a warning if the memory requirements are not met. Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-lang/zig')
-rw-r--r--dev-lang/zig/zig-0.10.1-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/zig/zig-0.10.1-r1.ebuild b/dev-lang/zig/zig-0.10.1-r1.ebuild
index 2325724c6f9e..cb8839ac166d 100644
--- a/dev-lang/zig/zig-0.10.1-r1.ebuild
+++ b/dev-lang/zig/zig-0.10.1-r1.ebuild
@@ -97,9 +97,9 @@ get_zig_target() {
pkg_setup() {
llvm_pkg_setup
- ewarn "This version requires 10G of memory for building compiler."
- ewarn "If you don't have enough memory, you can wait until 0.11.0 release"
- ewarn "or (if you are risky) use 9999 version (currently requires only 4GB)"
+ elog "This version requires 10G of memory for building compiler."
+ elog "If you don't have enough memory, you can wait until 0.11.0 release"
+ elog "or (if you are risky) use 9999 version (currently requires only 4GB)"
check-reqs_pkg_setup
}