summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-27 20:10:43 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-27 20:11:29 +0100
commitc38348609e2ee7bd933641cf32a03965fbf7a478 (patch)
tree917ad0f81be6f4fc13f200c8d0e700e64d6f5821 /dev-lang/python
parentapp-accessibility/nfbtrans: drop 7.74-r2 (diff)
downloadgentoo-c38348609e2ee7bd933641cf32a03965fbf7a478.tar.gz
gentoo-c38348609e2ee7bd933641cf32a03965fbf7a478.tar.bz2
gentoo-c38348609e2ee7bd933641cf32a03965fbf7a478.zip
dev-lang/python: Skip test_perf_profiler because of frequent failures
Bug: https://bugs.gentoo.org/933840 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-3.13.0-r100.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0.ebuild2
-rw-r--r--dev-lang/python/python-3.14.0_alpha1-r100.ebuild2
-rw-r--r--dev-lang/python/python-3.14.0_alpha1.ebuild2
4 files changed, 8 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.13.0-r100.ebuild b/dev-lang/python/python-3.13.0-r100.ebuild
index 7c26e550c713..b71dde63eb03 100644
--- a/dev-lang/python/python-3.13.0-r100.ebuild
+++ b/dev-lang/python/python-3.13.0-r100.ebuild
@@ -260,6 +260,8 @@ src_configure() {
COMMON_TEST_SKIPS=(
# this is actually test_gdb.test_pretty_print
-x test_pretty_print
+ # https://bugs.gentoo.org/933840
+ -x test_perf_profiler
)
# Arch-specific skips. See #931888 for a collection of these.
diff --git a/dev-lang/python/python-3.13.0.ebuild b/dev-lang/python/python-3.13.0.ebuild
index 19a37bf35253..74cbac81ba9e 100644
--- a/dev-lang/python/python-3.13.0.ebuild
+++ b/dev-lang/python/python-3.13.0.ebuild
@@ -262,6 +262,8 @@ src_configure() {
COMMON_TEST_SKIPS=(
# this is actually test_gdb.test_pretty_print
-x test_pretty_print
+ # https://bugs.gentoo.org/933840
+ -x test_perf_profiler
)
# Arch-specific skips. See #931888 for a collection of these.
diff --git a/dev-lang/python/python-3.14.0_alpha1-r100.ebuild b/dev-lang/python/python-3.14.0_alpha1-r100.ebuild
index d5b9029b2f08..9c556e225cfc 100644
--- a/dev-lang/python/python-3.14.0_alpha1-r100.ebuild
+++ b/dev-lang/python/python-3.14.0_alpha1-r100.ebuild
@@ -261,6 +261,8 @@ src_configure() {
COMMON_TEST_SKIPS=(
# this is actually test_gdb.test_pretty_print
-x test_pretty_print
+ # https://bugs.gentoo.org/933840
+ -x test_perf_profiler
)
# Arch-specific skips. See #931888 for a collection of these.
diff --git a/dev-lang/python/python-3.14.0_alpha1.ebuild b/dev-lang/python/python-3.14.0_alpha1.ebuild
index 54515a4293a2..acbfbfe8de8e 100644
--- a/dev-lang/python/python-3.14.0_alpha1.ebuild
+++ b/dev-lang/python/python-3.14.0_alpha1.ebuild
@@ -263,6 +263,8 @@ src_configure() {
COMMON_TEST_SKIPS=(
# this is actually test_gdb.test_pretty_print
-x test_pretty_print
+ # https://bugs.gentoo.org/933840
+ -x test_perf_profiler
)
# Arch-specific skips. See #931888 for a collection of these.