summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/tclib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/tclib')
-rw-r--r--dev-java/tclib/Manifest1
-rw-r--r--dev-java/tclib/metadata.xml6
-rw-r--r--dev-java/tclib/tclib-1.1.ebuild38
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/tclib/Manifest b/dev-java/tclib/Manifest
new file mode 100644
index 000000000000..9096dd992dc4
--- /dev/null
+++ b/dev-java/tclib/Manifest
@@ -0,0 +1 @@
+DIST tclib-1.1-source.jar 580130 SHA256 741deb4f4a86fe3523502038785f264740cb68bd8242f260bd03fd2274dcbe29 SHA512 69ef6b669986f638308d33ecd8c54393496c0b0019a175820e6dcf36a6479f8daad99aa4bc9613ee07da5f109620cc5ec5a9abd944dfd68aac60b47aeb585135 WHIRLPOOL b7fa545ffb9e52826692671eb5690ac1a61c601c9f0544c8f6842c7404a5ade5ef9f92edae3ec1b55dae04b2b9fba194f0371fe16eb9e3ec8a071e451b784ac2
diff --git a/dev-java/tclib/metadata.xml b/dev-java/tclib/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/tclib/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+
diff --git a/dev-java/tclib/tclib-1.1.ebuild b/dev-java/tclib/tclib-1.1.ebuild
new file mode 100644
index 000000000000..54197ded6ca2
--- /dev/null
+++ b/dev-java/tclib/tclib-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Type-Specific Collections Library"
+HOMEPAGE="http://www.sosnoski.com/opensrc/tclib/"
+SRC_URI="mirror://gentoo/${P}-source.jar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+java_prepare() {
+ find -name '*.jar' -print -delete
+ find -name '*.class' -print -delete
+}
+
+EANT_BUILD_XML="build/build.xml"
+EANT_BUILD_TARGET="package"
+
+src_install() {
+ java-pkg_dojar lib/tclib.jar
+ use source && java-pkg_dosrc build/src
+ use doc && java-pkg_dojavadoc build/docs
+}