summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-12-12 22:52:30 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-12-13 08:11:36 +0100
commit36590c60f059a5dc604e1691cb8b7e4a032cb841 (patch)
tree35fc5cf3ed5b4fe4dc4f32d802ece76286cd62e2 /dev-java/osgi-core-api
parentdev-libs/libpipeline: sparc stable wrt bug #829050 (diff)
downloadgentoo-36590c60f059a5dc604e1691cb8b7e4a032cb841.tar.gz
gentoo-36590c60f059a5dc604e1691cb8b7e4a032cb841.tar.bz2
gentoo-36590c60f059a5dc604e1691cb8b7e4a032cb841.zip
dev-java/osgi-core-api: EAPI 8, min java 1.8:*
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/23280/commits/a96be15c7b61ff41f2cb849bacbbe9014f5c73f4 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/osgi-core-api')
-rw-r--r--dev-java/osgi-core-api/osgi-core-api-5.0.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/osgi-core-api/osgi-core-api-5.0.0-r2.ebuild b/dev-java/osgi-core-api/osgi-core-api-5.0.0-r2.ebuild
new file mode 100644
index 000000000000..22a609e19717
--- /dev/null
+++ b/dev-java/osgi-core-api/osgi-core-api-5.0.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.osgi:org.osgi.core:5.0.0"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Service Platform Core API (Companion Code)"
+HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
+SRC_URI="http://www.osgi.org/download/r5/osgi.core-${PV}.jar"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x64-macos"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+DEPEND=">=virtual/jdk-1.8:*
+ app-arch/unzip"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+src_prepare() {
+ default
+ rm -r org || die
+}