summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-01-03 11:58:44 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-01-05 21:49:32 +0100
commit9896cd35982aa26d94a7f2949e399f714dae8930 (patch)
tree659b5d99ab55da6b9ef45b94fe03b478b5e20264 /dev-java/bcpg
parentdev-java/bcpkix: Remove unneeded slot (diff)
downloadgentoo-9896cd35982aa26d94a7f2949e399f714dae8930.tar.gz
gentoo-9896cd35982aa26d94a7f2949e399f714dae8930.tar.bz2
gentoo-9896cd35982aa26d94a7f2949e399f714dae8930.zip
dev-java/bcpg: Remove unneeded slot
Bug: https://bugs.gentoo.org/799749 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/bcpg')
-rw-r--r--dev-java/bcpg/Manifest1
-rw-r--r--dev-java/bcpg/bcpg-1.50-r1.ebuild70
-rw-r--r--dev-java/bcpg/bcpg-1.50-r2.ebuild73
3 files changed, 0 insertions, 144 deletions
diff --git a/dev-java/bcpg/Manifest b/dev-java/bcpg/Manifest
index 94094e36d49a..b7586bb46675 100644
--- a/dev-java/bcpg/Manifest
+++ b/dev-java/bcpg/Manifest
@@ -1,2 +1 @@
DIST bc-java-r1rv69.tar.gz 56587177 BLAKE2B be5321f48911840de70d3201c0436cf4147a25999abb605dc4c176ea9292796ca25633635d66dccab685a4bb162258c4495ccc764782119a0750ec1b7456a7db SHA512 5224f424faf549e8e3f2db1134e74647b09bebb654ed23bb0bcd493f065fdb3f2b4f2815be0137ebcc9d62b25a6725b7a26b76d55eb3ad014ad0ce92961126de
-DIST bcpg-jdk15on-150.tar.gz 691012 BLAKE2B ee566fb6deb44177e31bfe80b6bd1f13d39d6820cffe3693bd85314ccfd65c4805275b3925d52a6bda6b1ad7e3ea267f1f0bed3926420b5920e5f300020ecd9a SHA512 763d253b9bb45b7e7fab75d557daa784c3d4a503ced979adc986e5688c3939db248853c864a2f4bec6d5b1dd9ed668d5f278c91b5607774fc703971d0b330fe6
diff --git a/dev-java/bcpg/bcpg-1.50-r1.ebuild b/dev-java/bcpg/bcpg-1.50-r1.ebuild
deleted file mode 100644
index b895d1674885..000000000000
--- a/dev-java/bcpg/bcpg-1.50-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-pkg-simple
-
-MY_P="${PN}-jdk15on-${PV/./}"
-
-DESCRIPTION="Java cryptography APIs"
-HOMEPAGE="http://www.bouncycastle.org/java.html"
-SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="1.50"
-KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-# Tests are currently broken. Appears to need older version of bcprov; but since bcprov is not slotted, this can cause conflicts.
-# Needs further investigation; though, only a small part has tests and there are no tests for bcpg itself.
-RESTRICT="test"
-
-CDEPEND="dev-java/bcprov:${SLOT}"
-
-DEPEND=">=virtual/jdk-1.6
- app-arch/unzip
- test? (
- dev-java/ant-junit:0
- )
- ${CDEPEND}"
-
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-JAVA_GENTOO_CLASSPATH="bcprov-${SLOT}"
-
-src_unpack() {
- default
- cd "${S}"
- unpack ./src.zip
-}
-
-java_prepare() {
- if ! use test; then
- local RM_TEST_FILES=(
- org/bouncycastle/openpgp/test
- org/bouncycastle/openpgp/examples/test
- )
- rm -rf "${RM_TEST_FILES[@]}" || die
- fi
-}
-
-src_compile() {
- java-pkg-simple_src_compile
-}
-
-src_test() {
- local cp="${PN}.jar:bcprov.jar:junit.jar"
- local pkg="org.bouncycastle"
- java -cp ${cp} ${pkg}.openpgp.test.AllTests | tee openpgp.tests
- grep -q FAILURES *.tests && die "Tests failed."
-}
-
-src_install() {
- java-pkg-simple_src_install
- use source && java-pkg_dosrc org
-}
diff --git a/dev-java/bcpg/bcpg-1.50-r2.ebuild b/dev-java/bcpg/bcpg-1.50-r2.ebuild
deleted file mode 100644
index 6a89f6e93494..000000000000
--- a/dev-java/bcpg/bcpg-1.50-r2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-pkg-simple
-
-MY_P="${PN}-jdk15on-${PV/./}"
-
-DESCRIPTION="Java cryptography APIs"
-HOMEPAGE="http://www.bouncycastle.org/java.html"
-SRC_URI="http://polydistortion.net/bc/download/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="1.50"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-# Tests are currently broken. Appears to need older version of bcprov; but
-# since bcprov is not slotted, this can cause conflicts. Needs further
-# investigation; though, only a small part has tests and there are no tests for
-# bcpg itself.
-RESTRICT="test"
-
-CDEPEND="dev-java/bcprov:${SLOT}"
-
-DEPEND="
- ${CDEPEND}
- >=virtual/jdk-1.6
- test? ( dev-java/ant-junit:0 )"
-
-RDEPEND="
- ${CDEPEND}
- >=virtual/jre-1.6"
-
-S="${WORKDIR}/${MY_P}"
-
-JAVA_GENTOO_CLASSPATH="bcprov-${SLOT}"
-
-src_unpack() {
- default
- cd "${S}" || die
- unpack ./src.zip
-}
-
-src_prepare() {
- default
- if ! use test; then
- local RM_TEST_FILES=(
- org/bouncycastle/openpgp/test
- org/bouncycastle/openpgp/examples/test
- )
- rm -rv "${RM_TEST_FILES[@]}" || die
- fi
-}
-
-src_compile() {
- java-pkg-simple_src_compile
-}
-
-src_test() {
- local cp="${PN}.jar:bcprov.jar:junit.jar"
- local pkg="org.bouncycastle"
- java -cp ${cp} ${pkg}.openpgp.test.AllTests | tee openpgp.tests
- grep -q FAILURES *.tests && die "Tests failed."
-}
-
-src_install() {
- einstalldocs
- java-pkg-simple_src_install
- use source && java-pkg_dosrc org
-}