summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/backport-util-concurrent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/backport-util-concurrent')
-rw-r--r--dev-java/backport-util-concurrent/Manifest1
-rw-r--r--dev-java/backport-util-concurrent/backport-util-concurrent-3.1-r1.ebuild55
-rw-r--r--dev-java/backport-util-concurrent/backport-util-concurrent-3.1.ebuild55
-rw-r--r--dev-java/backport-util-concurrent/files/backport-util-concurrent-3.0-notest.patch14
-rw-r--r--dev-java/backport-util-concurrent/files/backport-util-concurrent-3.0-test.patch11
-rw-r--r--dev-java/backport-util-concurrent/metadata.xml12
6 files changed, 148 insertions, 0 deletions
diff --git a/dev-java/backport-util-concurrent/Manifest b/dev-java/backport-util-concurrent/Manifest
new file mode 100644
index 000000000000..fdd3843675de
--- /dev/null
+++ b/dev-java/backport-util-concurrent/Manifest
@@ -0,0 +1 @@
+DIST backport-util-concurrent-Java60-3.1-src.tar.bz2 622882 SHA256 1abecd12d48174dbf6fb0f39623ac954c7f0309870f18cca25afc870aeae2512 SHA512 caef9eef43d0de5ee3d05a84b44d3d2f6bb9498bdc82105626bd2631494fcd0347387da9beb6000fe9c80efacbbf2c2c3603a97b53e4c74037eaf629d790cd54 WHIRLPOOL fe8fdaa4942cf444f12867213bf6cc3897b2b79aebd818d41af677b8a9e69fa55466b93c74a50831345ddbe0c3413af2ede132c730dd0bbbcd9b2493e9697d79
diff --git a/dev-java/backport-util-concurrent/backport-util-concurrent-3.1-r1.ebuild b/dev-java/backport-util-concurrent/backport-util-concurrent-3.1-r1.ebuild
new file mode 100644
index 000000000000..9a251f880751
--- /dev/null
+++ b/dev-java/backport-util-concurrent/backport-util-concurrent-3.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+SF_PN="backport-jsr166"
+MY_P="${PN}-Java60-${PV}"
+
+DESCRIPTION="A portability wrapper for java.util.concurrent API (jsr166) 6.0"
+HOMEPAGE="http://${SF_PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${SF_PN}/${PV}/${MY_P}-src.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/junit:0
+ )
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${MY_P}-src"
+
+java_prepare() {
+ if use test; then
+ # make test not depend on make
+ epatch "${FILESDIR}/${PN}-3.0-test.patch"
+ else
+ # don't compile test classes
+ epatch "${FILESDIR}/${PN}-3.0-notest.patch"
+ fi
+
+ cd "${S}/external" || die
+ rm -v *.jar || die
+
+ use test && java-pkg_jar-from --build-only junit
+}
+
+EANT_BUILD_TARGET="javacompile archive"
+EANT_TEST_TARGET="test"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ dohtml README.html || die
+
+ use doc && java-pkg_dojavadoc doc/api
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/backport-util-concurrent/backport-util-concurrent-3.1.ebuild b/dev-java/backport-util-concurrent/backport-util-concurrent-3.1.ebuild
new file mode 100644
index 000000000000..904a29a18fa0
--- /dev/null
+++ b/dev-java/backport-util-concurrent/backport-util-concurrent-3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="doc source test"
+inherit java-pkg-2 java-ant-2
+
+SF_PN="backport-jsr166"
+MY_P="${PN}-Java60-${PV}"
+
+DESCRIPTION="A portability wrapper for java.util.concurrent API (jsr166) 6.0"
+HOMEPAGE="http://${SF_PN}.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${SF_PN}/${PV}/${MY_P}-src.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6
+ test? ( =dev-java/junit-3* )
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${MY_P}-src"
+
+java_prepare() {
+ if use test; then
+ # make test not depend on make
+ epatch "${FILESDIR}/${PN}-3.0-test.patch"
+ else
+ # don't compile test classes
+ epatch "${FILESDIR}/${PN}-3.0-notest.patch"
+ fi
+
+ cd "${S}/external"
+ rm -v *.jar || die
+
+ use test && java-pkg_jar-from --build-only junit
+}
+
+EANT_BUILD_TARGET="javacompile archive"
+
+src_test() {
+ eant test
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ dohtml README.html || die
+
+ use doc && java-pkg_dojavadoc doc/api
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/backport-util-concurrent/files/backport-util-concurrent-3.0-notest.patch b/dev-java/backport-util-concurrent/files/backport-util-concurrent-3.0-notest.patch
new file mode 100644
index 000000000000..65642012fddb
--- /dev/null
+++ b/dev-java/backport-util-concurrent/files/backport-util-concurrent-3.0-notest.patch
@@ -0,0 +1,14 @@
+--- build.xml.orig 2007-05-09 23:23:00.000000000 +0200
++++ build.xml 2007-05-09 23:23:34.000000000 +0200
+@@ -33,9 +33,9 @@
+ deprecation="true" destdir="${dest}" nowarn="false"
+ source="1.4" target="1.4">
+ <src path="src"/>
+- <src path="test/tck/src"/>
++<!-- <src path="test/tck/src"/>
+ <src path="test/loops/src"/>
+- <src path="test/serialization"/>
++ <src path="test/serialization"/>-->
+ </javac>
+ </target>
+
diff --git a/dev-java/backport-util-concurrent/files/backport-util-concurrent-3.0-test.patch b/dev-java/backport-util-concurrent/files/backport-util-concurrent-3.0-test.patch
new file mode 100644
index 000000000000..493738b6055d
--- /dev/null
+++ b/dev-java/backport-util-concurrent/files/backport-util-concurrent-3.0-test.patch
@@ -0,0 +1,11 @@
+--- build.xml.original 2007-02-10 02:03:52.000000000 +0100
++++ build.xml 2007-02-10 02:04:02.000000000 +0100
+@@ -107,7 +107,7 @@
+ -Djunit.ui=swingui property.
+ -->
+
+- <target name="test" depends="jdeps,make"
++ <target name="test" depends="jdeps"
+ description="runs TCK unit tests on the backport">
+
+ <property name="junit.ui" value="textui"/>
diff --git a/dev-java/backport-util-concurrent/metadata.xml b/dev-java/backport-util-concurrent/metadata.xml
new file mode 100644
index 000000000000..c61248a4b1f7
--- /dev/null
+++ b/dev-java/backport-util-concurrent/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ This package is the backport of java.util.concurrent API, introduced
+ in Java 5.0, to Java 1.4, and from Java 6.0 to Java 5.0"
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">backport-jsr166</remote-id>
+ </upstream>
+</pkgmetadata>